Highlighted
Absent Member.
Absent Member.
4378 views

Issue with recording in private mode browser...need urgently help pls

I am having trouble with recording the following route (privateapp)-(public app)-(Privateapp) using VUGEN. The issue is that the Private App is only acccessible when we connect to the VPN, and so the respective proxies have been automatically added to my browser. Now when I start my VUGEN recording it always opens up the browser like Chrome in incognito mode...i wonder why does it do that ? Can anyone help me to let me know the settings which would help me open the browser in a normal mode and not a private browsing mode.

0 Likes
5 Replies
Highlighted
Absent Member.
Absent Member.

Hi,

I suggest switching from the "Browser" recording mode to the "Windows Application" mode and recording Chrome.exe as an application (see attached image).

 

 

 

 

Highlighted
Absent Member.
Absent Member.

I too faced the same issue. Any resolution for this? Thanks

0 Likes
Highlighted
Absent Member.
Absent Member.

Hi,

 

I'm also facing the same issue with LR 12.50.  the issue exists for Chrome & Firefox browsers.  I tried following options.

1) Recording Mode-- Web Applications - I selected browser path (Chrome/Firefox) and the normal browser is opened, but no events are getting recorded.

2)When I try with Recording mode-Web Browser and select Firefox/Chrome from the dropdown, The browser is opened in incognito mode.

 

In both the cases, the events are not getting recorded. Refer screenshots for the same.

 

Please letme know if there is any patch available for this issue as soon as possible. Also, let me konw if this feature is working fine in any earlier versions. I need to assess the tool and suggest  a best tool to work on the same to my manager. 

 

Note: The tool is working fine with IE browser, but my applicaiton doesn't support IE browser. I need to work either on Firefox or Chorme.

0 Likes
Highlighted
Contributor.
Contributor.

HI,

Kindly provide the solution for this.

Vugen is launching the browser in "Private browsing" mode. We wan't that to be loaded in "normal" mode.

 

Thanks & Regards,

Srinivas.M

0 Likes
Highlighted
Absent Member.
Absent Member.

As my understanding you need to have the browser in normal mode when recording, however you are getting the private mode either in Firefox or Chrome. Generally, you can’t remove the private mode if you are using the Web Browser option, however, you can try the Windows Application option, thus, the private mode will be removed and it will record in normal mode, this can be done either in Firefox or Chrome.

 

Private modeprivate mode

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.