Highlighted
Respected Contributor.
Respected Contributor.
409 views

Issues in passing values within curly braces.

Jump to solution

Hi,

Below is the captured values while recording using web http html protocol and i have done parameterization using date function for dates(2018-01-29T17:31:17.233Z).

"Body={\"current_date\":\"2018-01-29T17:31:17.233Z\",\"employeeId\":\"802971\",\"lastModified\":\"2018-01-29T17:31:17.233Z\",\"statusFromBackend\":0,\"submitted\":false,\"target_hours\":\"\",\"total_time\":0,\"week\":{\"from\":\"2018-01-29T00:00:00.000Z\",\"to\":\"2018-02-04T00:00:00.000Z\"},\"timesheet\":[{\"status\":\"prefilled\",\"total_hours\":\"8.00 \",\"work_date\":\"2018-01-29T00:00:00.000Z\",\"workingDay\":1,\"project\":[{\"status\":\"prefilled\",\"activity\":\"Non Project Activity\",\""
"name\":\"Non Project Activity\",\"allocated\":0,\"editable\":true,\"task\":[{\"time\":\"7.58\",\"AWART\":\"9700\",\"TASKTYPE\":\"0002\",\"TASKLEVEL\":\"123\"},{\"time\":\"4.75\",\"AWART\":\"9700\",\"TASKTYPE\":\"0002\",\"TASKLEVEL\":\"121\"}],\"timespend\":12.33,\"resubmit\":false}]}]}", 

Remain values are given manulay for single run purpose. I checked with dev team also for the format and value is perfectly matched. 

Format and values got from dev team:

{"current_date":"2018-01-29T11:32:01.924Z","employeeId":"802971","lastModified":"2018-01-29T11:32:01.924Z","statusFromBackend":20,"submitted":true,"target_hours":"","total_time":0,"week":{"from":"2018-01-29T00:00:00.000Z","to":"2018-02-04T00:00:00.000Z"},"timesheet":[{"status":"prefilled","total_hours":"8.00 ","work_date":"2018-01-30T00:00:00.000Z","workingDay":1,"project":[{"status":"prefilled","activity":"Non Project Activity","name":"Non Project Activity","allocated":0,"editable":true,"task":[{"time":"5.17","AWART":"9700","TASKTYPE":"0002","TASKLEVEL":"123"},{"time":"5.25","AWART":"9700","TASKTYPE":"0002","TASKLEVEL":"121"}],"timespend":10.42,"resubmit":false}]}]}

Whenever i am hitting the URL and it seems empty curly braces"{}" in server side. Request HTTP status code is 200 in server log(loadrunner).  Anyone please help me on this.

Thanks in advance,

Regards,
Sakthirajan Kathirvel
0 Likes
1 Solution

Accepted Solutions
Highlighted
Respected Contributor.
Respected Contributor.

Hi Marcel,

Thanks for the suggestion.

I have checked snapshot pane, replay and recording is fine for the request.

While sending the data inside the body we need to be encrypt the data.

Issue has been resolved by "EncType=application/json;charset=utf-8".

Thanks

Regards,
Sakthirajan Kathirvel

View solution in original post

0 Likes
2 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Hi,

Did you check Snapshot pane to check what is different between recording and replay of that particular request ?

You can also use Fiddler or Wireshark to capture a replay from LR and one from browser to check what is different in order to find the cause of the issue.

 

0 Likes
Highlighted
Respected Contributor.
Respected Contributor.

Hi Marcel,

Thanks for the suggestion.

I have checked snapshot pane, replay and recording is fine for the request.

While sending the data inside the body we need to be encrypt the data.

Issue has been resolved by "EncType=application/json;charset=utf-8".

Thanks

Regards,
Sakthirajan Kathirvel

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.