Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..
1501 views

LG goes non-operational

Hi,

I have a small Sandbox test environment with 2 Load Generator servers. Our users execute small tests using 1 as controller and the other as LG. However, one of the LG's keeps going into non-operational status.

The tests are using Tru Client protocol so I have logged into the server using a domain account and configured it to run as process. After this I set the server to Operational in Lab Manager. But as soon as they try to initialize a test it goes non-operational again.

Version is 12.55.

In the eevnt log all I see is this info: 

Resource Recovery Task: Fail to recover Host LGServer. Reason: Failed to connect to load generator LGserver. Verify that Performance Center Agent Service is running on the load generator.

But the services appear to be running.

 

0 Likes
9 Replies
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: LG goes non-operational

Hi,

Your LG is standalone or PC host, if it is PC host, have you tried to run Host Configuration Wizard tool?

And please check from Controller, you can ping and telnet from it to LG machine via port 54345.

Regards,

Chau Nguyen | SW Technical Support Consultant.
LoadRunner and Performance Center


If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: LG goes non-operational

It is set up as a PC Host.

I re-ran the Host Config Wizard.

I can also ping and telnet from Controller to LG and from LG to Controller.

So I logged in to the server with the domain service account and then I clicked 'Agent Runtime Settings Configuration'.

I selected manual login to this machine and I got the message confirming it is running as a process.

Checked Lab Manager and made the LG Operational again.

However, as soon as the user tries to initialize a test it goes to Non-Operational again.

 

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: LG goes non-operational

Hello,

Hope you confirmed UAC is disabled.

Then, quickly run a system health check to confirm there is no a general issue with this configuration. All should be green.

Then, if you try to reconfigure the host from LAB Management is it successful? If not, then:

1\\Remove the host from LAB management and add it using IP address and check if the behaviour is the same? Is it ok?

2\\ if not, remove it and add it using FQDN?

1\\ and 2\\ are to confirm DNS is ok.

If the issue still persist, then open RDP to the problematic Host and take a look on

< PC Host Installation Folder\Temp>\ Performance Center_agent_service.log – this log might contain more detailed info about what happened and if there are something suspicious?

If all these steps passed, then you run a test and look on the logs in orchidtmp in:

1\\ PC server

2\\ Host used as controller

On one of that place there should be more detailed error description.

Good luck and all the best,

Ivo

IvoHri
0 Likes
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: LG goes non-operational

Ok so UAC is definitely disabled.

I did a health check in Lab Manager of each host and the performance center server. All passed as healthy.

When I try to reconfigure the host I get this error:


reconfig error.PNG

 

0 Likes
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: LG goes non-operational

So I tried to remove it and re-add it using both the server IP and its FQDN but I get the same error as above.

 

One thing to point out is that when I installed the PC server I used default IUSR_METRO.

But when I try to change this afterwards to a domain service account using the Utility in the bin folder I get an error saying the password is not meeting requirements etc...?

0 Likes
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: LG goes non-operational

Some more info from Performance Center Agent service log:

DriverLogger: Log started at 14/02/2018 05:53:30 .

14/02/2018 05:53:36 Error: Communication error: SSL accept error : [param not passed in call]. [MsgId: MERR-10344]
14/02/2018 05:53:39 Error: Communication error: The Client failed to send packet. The socket has been shut down. [MsgId: MERR-10343]
14/02/2018 05:53:39 Error: Communication error: The Client failed to send packet. The socket has been shut down. [MsgId: MERR-10343]
14/02/2018 05:53:39 Error: Two Way Communication Error: Function two_way_comm_post_message / two_way_comm_post_message_ex failed. [MsgId: MERR-60990]

DriverLogger: Log ended at 14/02/2018 06:02:32 .

0 Likes
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: LG goes non-operational

Also see this in the event log of the LG in Lab Manager:

 

Resource Recovery Task: Fail to recover Host LG. Reason: Failed to launch controller. Error: Error launching wlrun.exe. Reason: RunProcessWithLogOn: Failed to create process [D:\Program Files (x86)\HPE\LoadRunner\bin\wlrun.exe] with user[IUSR_METRO] windows error code[183]

 

I check admins group on the server and IUSR_METRO is definitely there

 

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: LG goes non-operational

Hello,

The issues comes because of the User and\or password mismatch of the PC System User. It is best to open a support ticket, however you might try the following on your own risk.

Please, try the following:

0\\ Remove the host from the lab management

1\\ Open LabManagment Project from Site Administration;

2\\ Find the table LAB_PC_SETTINGS

3\\ the first row contains the current PC System User the second row contains encrypted password

4\\ Copy the PC system user and the encrypted password in a notepad

5\\ Open RDP to the problematic host and navigate to the <PC Host installation >\dat and open LTS.config with an editor.Before doing anything create backup copy of that file and copy on a different place

6\\ In the <CommonSettings change the user and password with these you have previously taken from LAB Project. Note the password ends with “..”. The line below is an example.

<CommonSettings restRequestTimeout="3600" group="" is_sys_locked="false" user="Dom\PCSyS" password="VdfertGJHRsdrxVHFTFTYxx.." />

7\\ Save the file and try adding the host again. Preconfigure it, as to be sure it worked.

If that not working, then you definitely need to open a call to the support.

This should fix the issue.

All the best,

 

IvoHri
0 Likes
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: LG goes non-operational

In the end I had to reinstall performance center and it fixed the issue.

 

Tests were working fine for  while but now 1 of the Controllers ill not launch and it causes the server to go non-operational.

 

Resource Recovery Task: Fail to recover Host. Reason: Failed to launch controller. Error: Error launching wlrun.exe. Reason: RunProcessWithLogOn: Failed to create process [D:\Program Files (x86)\HPE\LoadRunner\bin\wlrun.exe] with user[IUSR_METRO] windows error code[183]

 

IUSR_METRO has all necessary permissions on the server.

DEP and UAC disabled.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.