Highlighted
Respected Contributor.. Respected Contributor..
Respected Contributor..
372 views

(LR) Support Tip - Issues with recording/replay of an RTE protocol scripts

An issue has been identified with the Powerterm Emulator that comes bundled with LoadRunner.

If AES cipher is used for establishing an SSH connection to a server, the emulator will wait for an user interaction (pressing a keyboard or a mouse button) prior to initiating the connection. The issue appears during recording and replay of RTE based scripts and also when the emulator is started manually by executing the command:
%vugen_path%bin\rtegate.exe -bypass

As a result, if no user interactions is detected, the recording/replay will fail. If the user clicks on the screen, the connection will be successfully initialized. 

Please check the following articles for further details and fixes for the issue:

Recording of RTE protocol script hangs before the login screen

Error in RTE protocol replay: TE_connect failed after 1 tries. Giving up.

Labels (1)
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.