Highlighted
Absent Member.. Absent Member..
Absent Member..
628 views

Load Test not Producing Needed Reports

Hello,
I ran a PC test successfully for 500 Vusers, with increments of 100 Vusers every 10 minutes (Summary Report attached). The problem is we are not getting the type of report we want.

We need to measure the transaction response time as the number of Vusers increase from 1 to 500. When I merged Average Transaction Response Time with Running Vusers, the graph only shows data for 100 Vusers. How can I set this up to make the graph show data for 500 Vusers?

Regards,

Effie Utuk

512-776-3866

0 Likes
7 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Load Test not Producing Needed Reports

Hi Effie,

It is impossile to determine anything from the screenshot you have attached. The summary report shows 100 maximum running Vusers. Did you ensure Vusers are running longer than 10 minutes to ensure concurrency really reaches to 200, 300, etc...

Can you share a screenshot of the running vusers graph?

Do you have any filter applied on the session or on the analysis template?

Can you share the RawResults.zip with me?

Thanks,

Shlomi 

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Load Test not Producing Needed Reports

Hi Shlomi,

Thanks for the information. I have attached a screenshot of the running vusers graph. The RawResults.zip was rejected because it's a wrong file type.  Is there another way I can send the RawResults.zip file to you?

How do I ensure that Vusers are running longer than 10 minutes to ensure concurrency really reaches to 200, 300, etc...? I don't believe I have any filters applied on the session or on the analysis template.

Please let me know if you need additional information to assist us accomplish our goal.

Thanks,
Effie

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Load Test not Producing Needed Reports

Hi Effie,

According to the Running Vusers graph there is nothing wrong with the summary report or the merged graph. You had a maximum of 100 Vusers running at any given point in time.

If you wish to run Vusers for a longer duration you should configure that in the scheduler. I suggest reading this section in the online help. Please skim all the pages there. I shared LoadRunner help page but it is actually identical in Performance Center as well.

I do not need the RawResults now. Next time you can simply rename the file extension from zip to png and upload it.

Regards,

Shlomi

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Load Test not Producing Needed Reports

Hi Shlomi,

Thanks again for the information. I am just beginning to do work on PC and load testing and I am running behind on this deliverable.

Could you please give me example on how to schedule this test so that the merged and summary reports can show data for all 500 vusers? I need to be able to examine the transaction response time for all 500 vusers. Please let me know if you need addtional information.

Thanks,
Effie Utuk
512-776-3866
Effie.Utuk@dshs.texas.gov

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Load Test not Producing Needed Reports

Hi Effie,

You should use Basic Schduler by group.

The first group should start right as the scenario begins for at least 50 minutes. in the screenshot below I designed it to run for one hour

The second group onwards will start with delay of 10 minutes comparing to the previous group and run 10 minutes less than the previous group. Example: the second group will start after 10 minutes and run for 50 minutes while the third group will start after 20 minutes and run for 40 minutes.

This way you ensure an overlap of the groups and an increasing workload. You can "play" with these definitions a bit to ramp up Vusers more gradually since running 100 Vusers at the same time is not recommended practice

Regards,

Shlomi

Scheduler.png

 

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Load Test not Producing Needed Reports

Thanks Shlomi,

One quick question...

Can the same script be used for all groups or use different script for each group.

Regards,

Effie

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Load Test not Producing Needed Reports

Hi Eddie,

Yes. You can add the same script multiple times to the same scenario.

Regards,

Shlomi

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.