Highlighted
Absent Member.
Absent Member.
8990 views

LoadRunner 11 cannot connect to SiteScope 11 Monitor

Jump to solution

Recently we started a POC for LR11 and SIS11 and making a SiteScope Monitor connection failed with a message: "Parsing error. Details: host , port 8080, line 9. Reason: Required white space was missing ... [MsgId: MMSG-47587]".

Can anyone please help?

 

P.S. This thread has been moved from Performance Center Support and News Forum to LoadRunner Support Forum. -HP Forum Moderator

0 Likes
1 Solution

Accepted Solutions
Highlighted
Absent Member.
Absent Member.

Re: LoadRunner 11 cannot connect to SiteScope 11 Monitor

Jump to solution

Try This.

For SiteScope with no configured authentication

1. Open SiteScope and configure monitors.
2. Verify that you can see the Topaz XML data at the URL:
http://localhost:8888/SiteScope/cgi/go.exe/SiteScope?page=topaz
3. Open C:\Program Files\HP\LoadRunner\dat\monitors\xmlmonitorshared.ini and edit the SiteScope section:

[SiteScope]
;ExtensionDll=SiteScopeMonExt.dll
MetricDataURL=SiteScope/cgi/go.exe/SiteScope?page=topaz
MetricListURL=SiteScope/cgi/go.exe/SiteScope?page=topaz&operation=config
DefaultPort=8888
DlgTitle=SiteScope Monitor
RefreshMetricList=1
EnableAccount=1
For SiteScope with authentication configured:

1. Open SiteScope and configure monitors.
2. Ensure your SiteScope admin has a password
3. Add a new SiteScope user with a user ID and password.
4. Verify that you can see Topaz XML data at the URL
http://localhost:8888/SiteScope/cgi/go.exe/SiteScope?page=topaz&account=login1
The â login=1â ³ part is the user index, for each user you add, the index increases by 1)
5. Open C:\Program Files\HP\LoadRunner\dat\monitors\xmlmonitorshared.ini and edit the SiteScope section.

[SiteScope]
;ExtensionDll=SiteScopeMonExt.dll
MetricDataURL=SiteScope/cgi/go.exe/SiteScope?page=topaz&account=login1
MetricListURL=SiteScope/cgi/go.exe/SiteScope?page=topaz&operation=config&account=login1
DefaultPort=8888
DlgTitle=SiteScope Monitor
RefreshMetricList=1
EnableAccount=1
QueryLoginInfo=1

View solution in original post

12 Replies
Highlighted
Absent Member.
Absent Member.

Re: LoadRunner 11 cannot connect to SiteScope 11 Monitor

Jump to solution
By the way: The LoadRunner 11 to SIS9.5 connection is succesful. So that means that there is a prob in the connection with SIS11.

Any help is appreciated.
0 Likes
Highlighted
Frequent Contributor.
Frequent Contributor.

Re: LoadRunner 11 cannot connect to SiteScope 11 Monitor

Jump to solution
I remember having the same problem with older versions of LR and SIS. When I used the old port 8888 the problem disappeared. Just try.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: LoadRunner 11 cannot connect to SiteScope 11 Monitor

Jump to solution
Since the problem is not hot at anyones attention I will leave it from here.

Feel free to share concerns because it will be a missing opportunity for HP to extend monitoring with SIS11.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: LoadRunner 11 cannot connect to SiteScope 11 Monitor

Jump to solution
I saw in the SIS11 docs that the classic interface (using port 8888) is disabled. It seems to me that a new interface must be used. Why HP gives you the opportunity to install SIS11 with the LoadRunner option.

I hope this is some food for thoughts, any input is appreciated.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: LoadRunner 11 cannot connect to SiteScope 11 Monitor

Jump to solution

Try This.

For SiteScope with no configured authentication

1. Open SiteScope and configure monitors.
2. Verify that you can see the Topaz XML data at the URL:
http://localhost:8888/SiteScope/cgi/go.exe/SiteScope?page=topaz
3. Open C:\Program Files\HP\LoadRunner\dat\monitors\xmlmonitorshared.ini and edit the SiteScope section:

[SiteScope]
;ExtensionDll=SiteScopeMonExt.dll
MetricDataURL=SiteScope/cgi/go.exe/SiteScope?page=topaz
MetricListURL=SiteScope/cgi/go.exe/SiteScope?page=topaz&operation=config
DefaultPort=8888
DlgTitle=SiteScope Monitor
RefreshMetricList=1
EnableAccount=1
For SiteScope with authentication configured:

1. Open SiteScope and configure monitors.
2. Ensure your SiteScope admin has a password
3. Add a new SiteScope user with a user ID and password.
4. Verify that you can see Topaz XML data at the URL
http://localhost:8888/SiteScope/cgi/go.exe/SiteScope?page=topaz&account=login1
The â login=1â ³ part is the user index, for each user you add, the index increases by 1)
5. Open C:\Program Files\HP\LoadRunner\dat\monitors\xmlmonitorshared.ini and edit the SiteScope section.

[SiteScope]
;ExtensionDll=SiteScopeMonExt.dll
MetricDataURL=SiteScope/cgi/go.exe/SiteScope?page=topaz&account=login1
MetricListURL=SiteScope/cgi/go.exe/SiteScope?page=topaz&operation=config&account=login1
DefaultPort=8888
DlgTitle=SiteScope Monitor
RefreshMetricList=1
EnableAccount=1
QueryLoginInfo=1

View solution in original post

Highlighted
Absent Member.
Absent Member.

Re: LoadRunner 11 cannot connect to SiteScope 11 Monitor

Jump to solution
Thnx for the award winning solution for authenticated configuration, because that worked fine.
0 Likes
Highlighted
Absent Member.
Absent Member.

subjecthere

Jump to solution

HTML in this post was causing errors on the Community, so with apologies, I had to remove the content of the post.

 

Warren_Admin, HP Enterprise Community Manager
Any personal opinions expressed are mine, and should not be interpreted as official statements on behalf of Hewlett Packard

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: LoadRunner 12 cannot connect to SiteScope 11 Monitor

Jump to solution

Thanks for the info.

 

Will this work for LoadRunner 12 and SiteScope 11.22 also.

 

I have upraded LoadRunner version 11.52 to 12 and are experienceing the same problem. I have tried various port configs and also connecting ways.

 

 

Error  I have (shown below) which is similar to original error mentioned above (however when I click my link then I do get to my sitescope server.

 

 

Parsing error.
Details: host mySiteScopeServer, port 8182, line: 10.
Reason: DTD is prohibited.

Contents:

 <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML>
<HEAD>
<BASE HREF="MyLocalSiteScopeURLFitsBetweenTheseBrackets">
<TITLE>Login - SiteScope</TITLE>
<META http-equiv=Content-Type content="text/html;charset=utf-8">

... [MsgId: MMSG-47587]

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: LoadRunner 12 cannot connect to SiteScope 11 Monitor

Jump to solution

Hi HeinReyneke,

 

try to use the port 8888 which is the default port for connecting (which differs from the the UI port)

 

This url should give an XML:

http://<SiS ip address>:8888/SiteScope/cgi/go.exe/SiteScope?page=topaz&operation=config&account=administrator

 

If so, then the LR connection should work also.

 

Goos luck 😉

 

Regards,

Aurél

0 Likes
Highlighted
Contributor.
Contributor.

Re: LoadRunner 11 cannot connect to SiteScope 11 Monitor

Jump to solution

Hi Praveen.

 

I am having similar difficulties and found this post.

 

When i type the address:
http://localhost:9080/SiteScope/cgi/go.exe/SiteScope?page=topaz&account=login1

Into the browser on my sitescope server i get "

404 - Page Unavailable

The page you are trying to access is unavailable."

 

If i try 8888 , i get the default "Firefox can't establish a connection to the server at localhost:8888." from the browser.

 

What should be my next steps?

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: LoadRunner 11 cannot connect to SiteScope 11 Monitor

Jump to solution

The comaptability can be checked on the matrix. unfortunately i do not have the link but will definetly share it once i find it. 

 

Always try to check for the port that Sitescope is listening to and the active port can be obtained from 

 

<Drive>SiteScope\groups  -> master.confif file. 

 

_httpActivePort=8081

 

this fixed my issue. Specify the machine name withe the port that is active and you are good to go.

 

But prior to all this kindly make sure "xmlmonitorshared.ini"  has the settings in place. As in when  installing, the port specified for sitescope should be same as the port value specifed in the [sitescope] section under dat/monitors -> "xmlmonitorshared.ini" file.

 

Hope this helps. Good Luck!

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.