Highlighted
Established Member..
Established Member..
852 views

LoadRunner 12.50 agent not opening all ports

Hi Everyone,

I have a strange issue with my LoadRunner 12.50 setup. Situation is as follows: one controller and two agents running on separate machines. Using the controller I execute a Citrix loadtest that used to run perfectly. This time, however, I see that the vusers running on one agent behave normally (i.e. not crashing and finishing the entire testrun), while vusers on the other agent crash randomly.

In the message/error output in the controller I see errors like:
-Error: Communication error: Server didn't get responsive select handle (user's call backs can't be called). mchan_pp_init API must be called first.

- Error: the remote host's status if 'Failed'. Check the remote host machine (and verify that it is not crashed). 

- Error: Exception was raised when calling per-thread-init function in extension CitrixClientImpl.dll: System Exception: EXCEPTION_ACCESS_VIOLATION

I tried reinstalling the entire LoadRunner setup on both agents, but the issue does not seem to resolve. While delving deeper into the issue, there seems so be somehting strange happening in the ports that the loadrunner agents are supposed to open. On the normally functioning agent the following ports are opened by the service: 443, 5003, 54345 and 50500. The failing agent only opens the ports 5003 and 54345. Note that the ports 50500 and 443 are not blocked and can be opened by any random process.

Does anybody know why the failing agent process does not open all ports it is supposed to open? To me this seems linked to the random vuser crashes. Reinstalling LoadRunner 12.50 does not seem to resolve this issue.

0 Likes
1 Reply
Highlighted
Absent Member.
Absent Member.

Re: LoadRunner 12.50 agent not opening all ports

Hi,

It is quite difficult to investigate crash cases within the forum, so I would ask you to open support ticket.   
Please try to replay your script on the problematic LoadGenerator manually, without Controller:
    <LG_INSTALLATION_DIR>\bin\mdrv.exe -usr <script's usr-file>
and check if this also causes to ACCESS_VILOATION - just to determine if issue is related to Citrix protocol implementation or to Controller/LG communication and to open a ticket with a proper description.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.