Highlighted
Established Member..
Established Member..
444 views

Loadrunner 12.50 for SAP GUI application testing

Hi,

I am trying to test SAP GUI application with LoadRunner 12.50 and 500Vuser for it.

One LG machine with 24 GB RAM and 8 CPUs 500 GB HDD.

SAP GUI Client v 7.20. 

Facing issues at several points in script while running it in Controller-LG. The script runs in VuGen with success.

I followed the steps given in the help document of LR 12.50.

But still not able to complete the scenario successfully in controller with different settings and tries.

Please share your experience on all the settings and things to be considered to carry out this test successfully.

 

Regards,

Milind Jadhav

 

0 Likes
2 Replies
Highlighted
Super Contributor.
Super Contributor.

Re: Loadrunner 12.50 for SAP GUI application testing

Hi, did you try taking small steps instead of the giant step directly from A to Z:

A: one single script in development mode in Vugen
Z: 500 virtual users in load mode on load generators through controller

 

May I suggest to try to take a first small step from A to B before continuing with the next small step?

A: one single script in development mode in Vugen
B: one single virtual user in load mode on load generator through controller

 

0 Likes
Highlighted
Contributor.
Contributor.

Re: Loadrunner 12.50 for SAP GUI application testing

Hello

I am having a similar issue mentioned in the original post.  My script records and runs fine in vugen and as single user mode in controller.  As soon as I add the second user, I seem to get random error messages. I say random because the message changes as I change the number of users or change the time interval when next user logs on. (error messages below)

I am still running a trial version of load runner for evaluation.  (not sure if that has something to do with it)

Running 12.6 version build 582 of controller and vugen.

SAP GUI 720 Final Release Patch 4

Load Runner/SAP GUI Wizards,  any idea what could be the issue?

 

 

CreateOrder.c(133): Error: Failed to set focus on "usr/tabsTAXI_TABSTRIP_OVERVIEW/tabpT\01/ssubSUBSCREEN_BODY:SAPMV45A:4400/ssubHEADER_FRAME:SAPMV45A:4440/ctxtRV45A-KETDAT"

CreateOrder.c(158): Error: Table - Failed to fill with data from Table parameter "{data_10}"

CreateOrder.c(191): Error: Failed to find SapGui component by ID "sbar"

CreateOrder.c(191): Error: Failed to get the status bar text

CreateOrder.c(191): Error: Failed to press button "Continue"

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.