Highlighted
xxsnikrzxx Respected Contributor.
Respected Contributor.
3203 views

Loadrunner 12.53 Vusers stuck at Pending

Jump to solution

I have two separate protocols running. The protocol that can actually initialize and run is Oracle NCA. As soon as I try and run an HTTP script through Loadrunner, it is stuck at pending.

If I have 1 Oracle NCA and 1 HTTP script running at the same time, both of them get stuck. If I just run the Oracle NCA, it works just fine. The settings are the same for both.

 

0 Likes
1 Solution

Accepted Solutions
xxsnikrzxx Respected Contributor.
Respected Contributor.

Re: Loadrunner 12.53 Vusers stuck at Pending

Jump to solution

I running a few hundred per protocol, but that number does not change anything when I increase or decrease.

No errors, the vusers just stay and pending, and say they are transferring files to Load Generators (I am using 6 of those).

Licensed edition as well.

 

I did fix it. I figured it was something with where LR was sticking the temp folders. In the design tab, Click a script and select details. Bottom right corner is a more button. Select the files tab. I have C:\TEMP selected. I unchecked this box and it worked fine. In the Tools > Options in the top of LR I have Runtime File Storage tab selected, and I have chosen "On the current Vuser machine". I believe this was coinciding with the C:\TEMP selection in the details section.

 

View solution in original post

3 Replies
Established Member.. LiorAvni
Established Member..

Re: Loadrunner 12.53 Vusers stuck at Pending

Jump to solution

Hi

How many users are you running per protocol?

are you getting any errors while running in Controller, or are the users simply stuck in "pending" state and no error messages are generated?

are you using the community edition or a licnesed version?

Thanks,

Lior

0 Likes
xxsnikrzxx Respected Contributor.
Respected Contributor.

Re: Loadrunner 12.53 Vusers stuck at Pending

Jump to solution

I running a few hundred per protocol, but that number does not change anything when I increase or decrease.

No errors, the vusers just stay and pending, and say they are transferring files to Load Generators (I am using 6 of those).

Licensed edition as well.

 

I did fix it. I figured it was something with where LR was sticking the temp folders. In the design tab, Click a script and select details. Bottom right corner is a more button. Select the files tab. I have C:\TEMP selected. I unchecked this box and it worked fine. In the Tools > Options in the top of LR I have Runtime File Storage tab selected, and I have chosen "On the current Vuser machine". I believe this was coinciding with the C:\TEMP selection in the details section.

 

View solution in original post

ESF
Visitor.

Loadrunner 12.62 Vusers stuck at Pending

Jump to solution

I launched 10 Truclient Vusers with 2 terminal sessions configuration (1 Terminal Session = 5 Vusers), and I encoutered the same issue. Someone knows a solution ? Thks.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.