Highlighted
Absent Member.
Absent Member.
1088 views

Loadrunner Replay Error - Hyperion EPM 11.1.2.4 login

Hi,

 

I have recorded a login to Hyperion Workspace 11.1.2.4 and on replay I am getting the following error after correlating sso_token:

 

Action.c(254): Error -26627: HTTP Status-Code=404 (Not Found) 

  [MsgId: MERR-26627]
Action.c(254): Warning -26200: At least one of the resources specified by EXTRARES has not been downloaded due to the above error(s)   [MsgId: MWAR-26200]
Action.c(254): web_submit_data("Adf.jsp_3") highest severity level was "ERROR", 768 body bytes, 268 header bytes   [MsgId: MMSG-26388]

 

 

The correlation created the following function call

 

    web_reg_save_param_regexp(
        "ParamName=RP_SSO_TOKEN",
        "RegExp=!\\[CDATA\\[(.*?)]]",
        SEARCH_FILTERS,
        "Scope=Body",
        "IgnoreRedirections=No",
        LAST);

 

The replay output does show that the parameter is being substituted.

 

Previous scripts that were recorded against 11.1.2.2 called web_reg_save_param which I understand is now deprecated. I also tried this same code snippet and it fails with the same error.

Code from 11.2.2.2 scripts:

 

 web_reg_save_param("RP_TOKEN_NO_ENCODING","LB=CDATA[","RB=]]></token>", LAST);

 

 

  

Any advise is appreciated.

 

 

0 Likes
5 Replies
Highlighted
Absent Member.
Absent Member.

Re: Loadrunner Replay Error - Hyperion EPM 11.1.2.4 login

Sharon did you resolve this issue my team and I are encountering a similar error in playback.
0 Likes
Highlighted
Trusted Contributor.
Trusted Contributor.

Re: Loadrunner Replay Error - Hyperion EPM 11.1.2.4 login

Please let me know if we get the solution for this issue
0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: Loadrunner Replay Error - Hyperion EPM 11.1.2.4 login

hi,

 

can you please provide more detailed replay log?

 

it looks like (from the error message) that one of the resources from the EXTRARES section ended with 404 error, maybe need to correlate the resource location?

Micro Focus Performance Core.
Functional Architect
your performance, our passion!
0 Likes
Highlighted
Super Contributor.
Super Contributor.

Re: Loadrunner Replay Error - Hyperion EPM 11.1.2.4 login

Hi,

We recently completed scripting Hyperion with LR 12.01. After a lot of struggle and searching blogs to find out the reason for error 404 Page Not Found, here is what we did.

1) Compared request header with replay header for the step which failed.

2) Found out a value XXXX_XXXX_CSRF (there were other values also but this mainly causes 404 error) was there in the request header which was not there in the replay request header.

3) Searched the CSRF value in response and correlated it

4) Manually added web_add_header and passed the correlated variable in it.

The script worked like magic 🙂 I'm sure if you follow these steps you can resolve the error 404 also.

Thanks

J Jena

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Loadrunner Replay Error - Hyperion EPM 11.1.2.4 login

Hello,

 

I have followed the below steps but still getting same issue.

 

Could you please help me 

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.