.Net filters doesn't work, still get error "Found an undefined object of type"

            #warning:  Code Generation Error
            // Found an undefined object of type Sectra.Client.Workstation.UrlIntegrationService. Assigning it the name singletonInstance_1.
            // Suggested solution: adding both this type, in assembly SectraWorkstation, Version=19.114.3605.26832, Culture=neutral, PublicKeyToken=a6af97a80a94638e, to the filter 
            // and/or any other types that return instances of this one.
            // Note:  This script will not compile as is.


I've tried including Sectra.Client.Workstation.UrlIntegrationService to the filters, like I have with other identical errors, but this one just continues with the same error despite adding the filter? I've also tried the following in the DotnetFilters XML document:

-<Namespace Name="Workstation" Action="Default">
	<Class Name="UrlIntegrationService" Action="Include">
		<Method Name=".ctor(System.Int32)" Action="Include"/>
	<Class Name="Program" Action="Default">
		<Method Name="CallWithUndefinedObject(Workstation.UrlIntegrationService)" Action="Include"/>


What do I do now to make sure UrlIntegrationService is fully included?


Labels (2)
0 Replies
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.