Highlighted
Absent Member.
Absent Member.
818 views

New Community Edition of LoadRunner is not providing the expected number of VUsers (50).

Hi,

Download LR from SaaS portal and installed it successfully.

Installed the LoadGenerators onto 4 other injector boxes. So totally 1 Controller Box + 4 Load Generator Boxes.

When I attempt to run a test on Single Protocol (Citrix ICA) as per the License availability of Community Edition, I'm supposed to get up to a maximum of 50Vusers and the License Utility also clearly shows this in green. But when I try to configure say even 10VUsers, I cannot. In each generator box I cannot increase the GUI Vusers to even to 2, it has to stay at 1 or the Generator configuration errors stating maximum number of VUsers is incorrect (not the exact words). So since I have 1 Controller and 4 injectors, I was only able to test it with 5 VUsers in total.

Raised a support ticket with HPE SaaS support (SD00209721) where I downloaded the LR Software and it has been more than 10 days and no response whatsoever from HP Support, hence seeking the community here to see if they can help me to identify the issue.

So to summarize, at the moment with the LR Community Edition, I'm unable to test with more than 5VUsers? Whereas the License Utility clearly shows be that I'm allowed to use upto 50 GUI VUsers. I'm only exercising Citrix ICA Single Protocol Script.

Any help or direction to fix this issue will be much appreciated.

Thanks,

Nanda

0 Likes
7 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: New Community Edition of LoadRunner is not providing the expected number of VUsers (50).

Hi

one question - are you trying to run Citrix protocol, or GUI Vuser protocol?

the community edition does give you 50 Vusers for free for all protocols, with the exception of COM/DCOM and GUI Vusers.

so just to be clear, you created a Citrix protocol script and you are trying to run it in Controller for more 10 Vusers and it is giving you the error message, correct?

if it is a Citrix protocol script, can you try running on the local machine? I mean not Vs a remote LG, but on the localhost and let us know if the error message recours.

Thanks,

Lior

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: New Community Edition of LoadRunner is not providing the expected number of VUsers (50).

I thought Citrix is part of the GUI VUser group.

But yes, I was just trying with Citrix ICA Protocol (which would invoke a XenApp to work on SAPGui), but from scripting prespective it was a single protocol selection of Citrix ICA only.

I will try to load all the 10VUsers running the same Citrix ICA Script from the Controller Box alone (localhost) but the script itself will invoke a connection to Citrix Server Box via ICA communication. And will report back here by tomorrow mid-day, whether I was successful in doing that or not.

If I have misunderstood your reply, please clarify in the meantime.

Many thanks for your time AvniLior, sincerely appreciate it.

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: New Community Edition of LoadRunner is not providing the expected number of VUsers (50).

Hi,

Just to confirm, yes I'm able to run all the 10VUsers from the localhost (Controller box) successfully using the same ICA protocol test script. I tried running them as 'Run Vuser as a thread' as well as 'Run Vuser as a process' and in both cases I was able to go upto 10Vusers easily.

So what is preventing me from doing this via the Remote Injectors/Generators installed on to 4 separate boxes?

Any ideas?

Many thanks for your time.

 

 

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: New Community Edition of LoadRunner is not providing the expected number of VUsers (50).

Hi

Thank you for confirming.

I will try to recreate it internally and update with the results.

out of curiousity - can you try to run with a different protocol on the same setup? i.e. 4 stand alone LGs of 12.53 community edition, 10 Vusers on each? try a simple web script and let us know.

Thanks,

Lior

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: New Community Edition of LoadRunner is not providing the expected number of VUsers (50).

Hi Lior,

Just to confirm, yes I was able to successfully execute 50VUsers across all four injectors + controller boxes (20% load sharing across - 10 VUsers) across each injectors and it successfully ran to a maximum of 50VUsers.

Did you manage to find similar issues in your local replication?

Thanks for your time and efforts in helping me, sincerely appreciate it.

Regards,

Nanda

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: New Community Edition of LoadRunner is not providing the expected number of VUsers (50).

Hi Nanda,
so this may be a citrix protocol limitation with the community license. For now, I suggest that if you need to run citrix protocol that you use the localhost as your load generator. We will continue to research this internally.
I will update if a conclusion is found.
Thanks
Lior
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: New Community Edition of LoadRunner is not providing the expected number of VUsers (50).

I think you need to enable terminal services on the load generators in the agent setup for Citrix? And then configure each load generator in your Controller scenario to use terminal services too.

And yes, you need to run users as a process for Citrix.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.