Highlighted
Super Contributor.
Super Contributor.
273 views

Problem with malformed BASE tag in HTML recording

Hi all,

during replay a web application in HTML-mode with option "download non-HTML resources" on i get lot of http-400 errors for html and non-html content. Looking at the source code of the site i found the header tag

<BASE href="./">

vUGen tries to download resources (even html and non-html) with the URL

http://server.domain.tld./content.html

Cause for the 404-errors seems to be the "." after tld.

It is neccessary for the script to download content dynamically, URL-Mode is not an option.

Does someone here facing the same problem?

Any suggestions to work with the malformed html-header (i.e. web_add_header)?

 

Thanks in advance, Christoph

0 Likes
1 Reply
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Problem with malformed BASE tag in HTML recording

Hi Christoph,

Did you try recording in HTML level? You can change the settings in recording options dialog.

Alternatively, you can use traffic filtering to filter out these requests.

Regards,

Shlomi 

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.