Highlighted
Regular Contributor.
Regular Contributor.
270 views

Questions about websockets and authentication

Hello All!

I am new with websockets and the logic to use them on the HTTP protocol. I was able to record them and I see the custom API's created by the recording.

However, when the first web_sockect_connect is attempted, the error I got is completely unrelated (or it is what I think): "Error -26547: Authentication required, please use 'web_set_user....' "

I tried to do the simplest connection, but is not reaching any of the OnOpenCB, OnMessageCB or OnErrorCB functions.

Usually, these errors are related with proxy. However, I reviewed the browser setup and there is nothing related to proxy or vpn. It's a direct conneciton.

Finally, I just wanted to check if the script was dependent of those calls. I commented them out and the script works without problems. Therefore, not sure why this errors pops up. I just know is related with the websocket call.

Could someone give me a hint on what is going on?

I appreciate the help!

Regards

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.