Highlighted
Trusted Contributor.
Trusted Contributor.
261 views

Re: HTTP Status-Code=401 (Unauthorized) error in LoadRunner ApplicationType:Appian

I have recorded the scripts through loadrunner and while replay the scripts i am getting the 401 error.

While replay it suggests me to provide web_set_user, I used following statement before the specific request.

web_set_sockets_option("SSL_VERSION", "2&3");    
    web_set_user("Domain\\username", "password", "locahost:port");
    web_set_sockets_option("INITIAL_BASIC_AUTH","1");
    web_cleanup_cookies();
    web_cache_cleanup();

Error -26630: HTTP Status-Code=401 (Unauthorized) getting an error while replay the scripts.

Run Time Settings:

Use cusom proxy:Use proxy server details-selected and Use same proxy server for all the protocols-Checked.

Also provided authentication details from the "Authentication" tab

Can you pls suggest.

 

JS
0 Likes
1 Reply
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Hi JS, 

have you try to select "Use WinInet replay instead of Sockets (Windows only)" from section "Internet Protocol -> Preferences" from Runtime Settings? Try it and let me know if this simple suggestion can help you with the issue.

Lorenzo

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.