Highlighted
Frequent Contributor.
Frequent Contributor.
5784 views

Recoding RDP Protocol with mstsc will dropping out an error.

Jump to solution

Hi
When I use the LoadRunner12.55 to recode the RDP session, it drops out error:

---------------------------
Remote Desktop Connection
---------------------------
Because of an error in data encryption, this session will end. Please try connecting to the remote computer again.


If I remote the machine without recoding, it will not have any error.
My workstation is Win 10 Pro, and I regularly RDP to servers and PCs on the LAN - a mixture of Win 7, Win2k3, Win2k8 and Win2k8 R2.

Thanks.

0 Likes
1 Solution

Accepted Solutions
Highlighted
Respected Contributor.
Respected Contributor.

回复: Recoding RDP Protocol with mstsc will dropping out an error.

Jump to solution

Hi, 

It is a limitation when recording mstsc.exe on Windows 10, if the RDP server side enables FIPS, the default recording will throw an error of "data encryption".

You could try below workaround:

1. Turn off FIPS at server side,Untitled picture.png

or

2. Use SSL recording mode.

  • Open mstsc, fill RDP server in the dialog, click "options" to expand detail options, and click "Save As" to save the configuration to a file (name it "RDPConfig.RDP" here).
  • open "RDPConfig.RDP" with notepad, add "enablecredsspsupport:i:0" at the bottom. Search for "authentication level" in the same file, make sure this line is "authentication level:i:2".
  • Goto LoadRunner's dat folder, open rdp_ro.ini with wordpad or notepad++ (don't use notepad because of newline characters issue), add "SupportSSL=1" at the bottom.
  • After "start recording", click on "Options" in RDP client, then press "Open", choose the "RDPConfig.RDP" file we saved in step 1. Then click "Connect"

Thanks,

Maggie

View solution in original post

0 Likes
2 Replies
Highlighted
Respected Contributor.
Respected Contributor.

回复: Recoding RDP Protocol with mstsc will dropping out an error.

Jump to solution

Hi, 

It is a limitation when recording mstsc.exe on Windows 10, if the RDP server side enables FIPS, the default recording will throw an error of "data encryption".

You could try below workaround:

1. Turn off FIPS at server side,Untitled picture.png

or

2. Use SSL recording mode.

  • Open mstsc, fill RDP server in the dialog, click "options" to expand detail options, and click "Save As" to save the configuration to a file (name it "RDPConfig.RDP" here).
  • open "RDPConfig.RDP" with notepad, add "enablecredsspsupport:i:0" at the bottom. Search for "authentication level" in the same file, make sure this line is "authentication level:i:2".
  • Goto LoadRunner's dat folder, open rdp_ro.ini with wordpad or notepad++ (don't use notepad because of newline characters issue), add "SupportSSL=1" at the bottom.
  • After "start recording", click on "Options" in RDP client, then press "Open", choose the "RDPConfig.RDP" file we saved in step 1. Then click "Connect"

Thanks,

Maggie

View solution in original post

0 Likes
Highlighted
Frequent Contributor.
Frequent Contributor.

回复: Recoding RDP Protocol with mstsc will dropping out an error.

Jump to solution

Thanks!

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.