Highlighted
Absent Member.. Absent Member..
Absent Member..
1910 views

Recording issue observed with VUGen TruClient (12.50) while login to Salesforce application

Dear HPE Community Members,

There is a recording issue with VuGen TruClient (12.50) while login to the Salesforce application

Steps:

- Open TruClient 'Develop Script' for Firefox browser

- Select a Salesforce application (Lightning experience mode) and start recording

- Type the valid user credential (user id and password) and click on login button

- The Salesforce home page is not loading, hence further steps couldn't get recorded.

Note: There is no any issue observed while navigating similar steps manually. The Salesforce home page get loaded successfully.

Other Required information:  VuGen 12.50, Firefox 47.0.1

Please let me know if any additional information required.

Thanks in advance for the quick response.

Regards,

Shiv

 

0 Likes
12 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Recording issue observed with VUGen TruClient (12.50) while login to Salesforce application

Hi,

12.50 was released with an older Firefox version 37.02. Are you sure the firefox version didn't updated by mistake?

Please note that checking the firefox version from TruClient might trigger an update while TruClient require a specific version of Firefox.

1. Please copy the firefox folder from <LR/VUEGN>\bin to C::\temp

2. Check firefox.exe properties under C:\Temp\firefox folder. What is the version?

3. Open the browser and try to login to Salesforce. Is it successful?

Regards,

Shlomi

 

 

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Recording issue observed with VUGen TruClient (12.50) while login to Salesforce application

Hi Shlomi,

Thanks for your prompt reply.

I've performed the setps as you mentioned and observed following.

- Firefox version is 37.0.2

- Manually navigate the Salesforce application on Firefox 37.0.2 and found error message as below:

Sorry to Interrupt
This page has an error. You might just need to refresh it.
[NoErrorObjectAvailable] UnknownError

Hence this means, our Salesforce application do not support on Firefox 37.0.2

 

So, Now I've started recording using IE, but observed an issue with the TruClient. The following information displayed on the TruClient for IE Browser tab:

Stronger security is required.

To access this website, enable TLS 1.1 and TLS 1.2.

Click the  gear icon or the  Tools button near the top-right corner of this window and select "Internet options".

Click the "Advanced" tab. Scroll down the list and select "Use TLS 1.0", "Use TLS 1.1", and "Use TLS 1.2".

For additional security, uncheck "Use SSL 2.0" and "Use SSL 3.0". When complete, the window should resemble the following:

 

I've performed the steps as suggested above, but it didn't work

Appreciate if you provide the solution for this issue as well.

 

Thanks in advance

Shiv

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Recording issue observed with VUGen TruClient (12.50) while login to Salesforce application

Hi,

I know about other customers who used TruClient Firefox to test Salesforce application using 12.02, hence 12.50 should work as well. I am not sure what is your implementation but Salesforce supports Firefox 37.0.1

In order to configure TruClient IE you need to open General Settings and select the right TLS settings in the Browser Settings tab. The changes you did in Microsoft IE do not apply on TruClient IE.

Regards,

Shlomi

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Recording issue observed with VUGen TruClient (12.50) while login to Salesforce application

Hi Shlomi,

Thanks for providing the additional information for TruClient IE setup.

I've tried all the options (SSL3.0, TLS 1.0, TLS 1.1, TLS 1.2) seperately in TruClient General Settings <Browser Settings>, but getting the same message as below for each settings.

Stronger security is required.

To access this website, enable TLS 1.1 and TLS 1.2.

Click the  gear icon or the  Tools button near the top-right corner of this window and select "Internet options".

Click the "Advanced" tab. Scroll down the list and select "Use TLS 1.0", "Use TLS 1.1", and "Use TLS 1.2".

For additional security, uncheck "Use SSL 2.0" and "Use SSL 3.0". When complete, the window should resemble the following:

 

Please suggest other options for the resolution.

Thanks,

Shiv

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Recording issue observed with VUGen TruClient (12.50) while login to Salesforce application

Hi,

Please open support call and HPE support will assist you.

Regards,

Shlomi

0 Likes
Highlighted
Valued Contributor.. Valued Contributor..
Valued Contributor..

Re: Recording issue observed with VUGen TruClient (12.50) while login to Salesforce application

Hi, we have the same issue with LoadRunner v12.53 build 1203.

We could record using Truclient IE on the TLS1.0-web app. When they change to TLS1.2, we see the message: This page cant be displayed

Turn on SSL 3.0, TLS 1.0, TLS 1.1 and TLS 1.2 in Advanced settings and try connecting to .....

In Trueclient IE settings, we try all radio-button options ssl3.0, tls1.0, tls1.1 and tls1.2, but same error message.

0 Likes
Highlighted
Valued Contributor.. Valued Contributor..
Valued Contributor..

Re: Recording issue observed with VUGen TruClient (12.50) while login to Salesforce application

Note: it works with Truclient Chromium on the same TLS1.2 web, but our requirements is for IE.

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Recording issue observed with VUGen TruClient (12.50) while login to Salesforce application

Hi,

Can you please install patch 4?  I am pretty sure the fix for this issue was included in it.

If you cannot install the patch open a support ticket.

Regards,

Shlomi

Highlighted
Valued Contributor.. Valued Contributor..
Valued Contributor..

Re: Recording issue observed with VUGen TruClient (12.50) while login to Salesforce application

Hi Shlomi,

thanks for the quick rely! The latest LR patch is still 3, released early 2016.

/t5/LoadRunner-Information-and-News/LoadRunner-12-50-Patch-3-released/td-p/6823429

Patch 4 is released for UFT only, not for LoadRunner! Please advice if you can find a patch 4 for LoadRunner!

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Recording issue observed with VUGen TruClient (12.50) while login to Salesforce application

I got confused sorry. I was sure you already have 12,.53 installed. Apparently you have 12,.50 patch 3. There is a big difference.

You are right, there is no patch 4 for 12.50 in LoadRunner. There is one for LoadRunner 12.53.

I suggest opening a ticket or upgrading to 12.53 patch 4

Regards,

Shlomi

Highlighted
Valued Contributor.. Valued Contributor..
Valued Contributor..

Re: Recording issue observed with VUGen TruClient (12.50) while login to Salesforce application

Awesome, it now works with the LR 12.53 patch 4. Thanks!

Got the patch from here:

https://softwaresupport.hpe.com/km/KM02688589

  • Error: This page can't be displayed. Turn on TLS 1.0, TLS 1.1, and TLS 1.2 in Advanced settings and try connecting again in TruClient IE
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.