Highlighted
Visitor.
263 views

Running VU Script on LSRetail WebPOS

Some help needed to a LoadRunner rookie

The VU replay is looking fine, BUT nothing is executed on the LSRetail WebPOS i a Chrome Browser - Running the VU script

Application Name: HP Virtual User Generator Version: 12.53.1203.0

Even though we are running a trail version, we should be able to exetute som sales in at WebApplication running on Dynamics Navision and LSretail POS system?

Br.

Peter Langkjær

 

0 Likes
8 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Running VU Script on LSRetail WebPOS

Hi Peter,

You say that replay is looking fine but nothing is executed. what do you mean?

are you running the script and cheking the application at the same time?

Also, are you using web protocol or TruClient?

Thanks,

Lior

0 Likes
Highlighted
Visitor.

Re: Running VU Script on LSRetail WebPOS

Hi Loir

Yes, I'm runing the VU Generator > Replay F5, expecting the VU Generator to exetute actions (eg Sales in POS system this case) in the Web Browser.

I'm using Web Protokol

Br

Peter 

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Running VU Script on LSRetail WebPOS

Hi Peter,

and how do you know that the actions were not executed? not second guessing you or something, just trying to get the full picture 🙂

you run the script and than logged in with the same user that run the script to the application through a different browser session?

what does your script do? are you deleting the data at the end of the script? 

Thanks,

Lior

Highlighted
Visitor.

Re: Running VU Script on LSRetail WebPOS

Hi Lior
The scpript performs a sale on a browserbased POS system.
I've attached the Action Script and (Note the init Script is not attached)

 

 

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Running VU Script on LSRetail WebPOS

Hi Not sure you can attache a script here, but try anyway (nothing was attached to the current message). my question is - are you trying to verify the success of the script with the same user that logged in to the application when the script was replayed? Thanks, Lior
0 Likes
Highlighted
Visitor.

Re: Running VU Script on LSRetail WebPOS

I'm not deleting anything (to my knowlegde). I'm just assuming that the replay accually executes the same actions in the "live" browser according to the script i just recorded.
I've attached the Init Script in this reply 

0 Likes
Highlighted
Visitor.

Re: Running VU Script on LSRetail WebPOS

Yes, its the same user as the one used to generate the script. I've closed the browser before hitting the Replay button 

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Running VU Script on LSRetail WebPOS

Hi Peter,

nothing is attached still... 😞

perhaps clear the cache of the "real" browser before checking? or check with an incognito instance of a browser?

can you try a different business process to see if this is a different problem?

Thanks,

Lior

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.