Highlighted
Absent Member.
Absent Member.
2627 views

Set Proxy for Loadrunner TruClient

How to set proxy in Loadrunner TruClient IE for all users.

Each time I login with a different user it fails to recognize proxy settings.

I run it via batch file so needs to run it with different users.

I have to go and set it each time to for each individual user.

 

Is there a way to set the proxy within the script so that it doesn't fails.

 

Thanks in advance

 

Kind Regards,

Amit

Tags (1)
0 Likes
6 Replies
Highlighted
Absent Member.
Absent Member.

Re: Set Proxy for Loadrunner TruClient

Hello,

 

You can set proxy setting form Runtime setting->Load Mode Browser setting:

 

 

 

Thanks,

Deepak

Highlighted
Absent Member.
Absent Member.

Re: Set Proxy for Loadrunner TruClient

Hi Deepak..thank you very much for your reply.

 

Is there any way i can authenticate the proxy.

 

Thanks

 

Kind regards,

Amit

0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: Set Proxy for Loadrunner TruClient

1. In the url address field in Firefox, enter about:config.
2. Click the I'll be careful, I promise! button.
3. In the Filter field, enter network.negotiate-auth.allow-proxies.
4. Right click network.negotiate-auth.allow-proxies and select Toggle. This changes the value to false.
5. Record the initial navigation step again. You also need to record entering the Proxy Authetication username and password, you will notice this is recorded as "sub steps" under the navigation step. You record authentication as you will be prompted on every iteration of the "Action".
Regards,
Gagandeep Malviya

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution
0 Likes
Highlighted
Valued Contributor.
Valued Contributor.

Re: Set Proxy for Loadrunner TruClient

My problem also concerns proxy authentication, but the solution suggested by Gagandeep is not relevant as this setting is already set to false in my TruClient browser. The way I have attempted to resolve this is to insert a 'Dialog - Authenticate' step in the test immediately after the intial 'Navigate' step that connects to the web site. This works in Interactive Mode. I have also inserted a Catch Error step immediately afterwards in case a 401 is not returned. So what is my problem exactly? In load mode, the test is still unable to connect to internet resources. I assume this is because the credentials entered in the 'Dialog - Authenticate' step are not cached. Of course, I cannot control exactly when a 401 will be returned; hence my test cannot get to the internet resources via the web proxy. So what can I do? Well I can't run the script engine as a domain user due to a defect in LoadRunner (I've already raised an ER for this: https://softwaresupport.hp.com/group/softwaresupport/search-result/-/facetsearch/document/LID/QCCR1J78685 So, does anyone know how exactly I can get my test to authenticate with the proxy? Or have I just got to accept that HP have once again left their customers in the lurch with only half a solution.
0 Likes
Highlighted
Established Member..
Established Member..

Re: Set Proxy for Loadrunner TruClient

To get proxy to work, I had to edit file  ScriptName\default.cfg.

After you save your script and before you create the zip file add or modify 2 lines to default.cfg in section [TruClient]

AutoConfigURL=http://proxy-support.boeing.com:31060/proxy.pac
ProxyType=2

Good luck, you will need it.

0 Likes
Highlighted
Established Member..
Established Member..

Re: Set Proxy for Loadrunner TruClient

I forgot to add, after modifying default.cfg, now the script will not execute on desktop but will execute on BPM
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.