Highlighted
Absent Member.. Absent Member..
Absent Member..
1010 views

Set Username and Password Before Recording

Hi, all.

I have been creating a VuGen script for our company's web application using Web - HTTP/HTML protocol. However, the web application uses an authentication method that automatically detects and uses my Windows login credentials as username and password to the web app. I am using a computer with Windows login that DOES NOT have access to the web app, hence, causing me to land in the authentication error page of my web app.

Is there a way that I can make Mercury Web Recorder NTML Authentication appears before/during recording (see screenshot)? Because this only appears after recording where it detects that during recording, it needs to download resources that requires authentication.

Or is there another way for me to set my username and password during recording?

I have the following constraints though:

1. I do not have access to a Windows account which has access to the application.

2. We cannot change the design of the application or make any code changes to the application.

Thanks, all.

0 Likes
4 Replies
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: Set Username and Password Before Recording

Hi,

You can try to uncheck the option 'Enable Integrated Windows Authentication' in IE browser/ Internet Option/ Advanced. After that close IE and access to your application again, a Windows popup should be opened to input your username and password.

IE.PNG

Regards,

Chau Nguyen | SW Technical Support Consultant.
LoadRunner and Performance Center


If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Set Username and Password Before Recording

Hi, doing the above setting in IE was not able to turn off the feature. But, in Firefox, the web application asks for the credentials so I record using Firefox instead and after recording the NTLM Authentication of HP LoadRunner appeared and I entered the info and this was included in the script generated (web_set_user). However, during replay, I am getting unauthorized responses from the server.

I tried checking and unchecking Authentication settings in Runtime Settings that is related to NTLM authentication but the response is the same. Can you tell me the exact settings that I should checked/unchecked?

Or is this related to the web_custom_request that is sent because in the VuGen script, there are parts that are related to the time/timezone? Please refer to VuGenScript.png. I cannot correlate the timezone.

What should I do?

Thanks for the help.

0 Likes
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: Set Username and Password Before Recording

Hi,

Could you please open a support ticket and provide the script so that we can check the issue?

You can open the ticket from this site: https://softwaresupport.hp.com, choose Dashboards/ Service Requests/ Submit New and choose type: Product technical issue.

Regards,

Chau Nguyen | SW Technical Support Consultant.
LoadRunner and Performance Center


If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Set Username and Password Before Recording

Hi tester11

Regarding your question about the date and time, you can use the Date/Time parameter type in Vugen to send the current time to the server. 

Your date/time format has a T in the middle and Z at the end which you can add in the Date/Time format textbox.

DateTimeParam.png

You can even get the current time from a different time zone. For details check the following KM: 

https://softwaresupport.hp.com/group/softwaresupport/search-result/-/facetsearch/document/KM02702477

After your ticket with support is resolved,  can you please share the resolution with us so that the other members in the forum can benefit from the solution as well. 


Thank you in advance. 

Kind regards, 
Vesela 

 

HPE Support
If you haven’t tried it yet, come and join us in our entitled forums at Support Customer Forums

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution and give Kudos to the author for their assistance.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.