Linda Marzik Respected Contributor.
Respected Contributor.
2246 views

TCS has stopped working" error when starting TruClient IE script in LR12

Trying to script on Windows 2008 with LR V12.

TruClient with FF works fine.

TruClient with IE is getting an error of "TCS has stopped working"

Inital research has shown problems with security software.   These servers were built for LR and don't have any security software installed.

Also thought about DEP ... did command bcdedit /set nx AlwaysOff .. as admin, but still get the error.

 

Need help to resolve.  The client would prefer all testing to be done in IE.  

 

 

0 Likes
16 Replies
Guy_Rosenthal Absent Member.
Absent Member.

Re: TCS has stopped working" error when starting TruClient IE script in LR12

Hi,

Have you turned off the ESC feature?

http://blogs.technet.com/b/chenley/archive/2011/03/10/how-to-turn-off-ie-esc.aspx

 

 

Thanks.

Guy Rosenthal
Network Virtualization PM
0 Likes
Linda Marzik Respected Contributor.
Respected Contributor.

Re: TCS has stopped working" error when starting TruClient IE script in LR12

I have not turned this off ... actually didn't know it existed.   I will give try this and let you know if it works.

Thank you for the suggestion.

0 Likes
Linda Marzik Respected Contributor.
Respected Contributor.

Re: TCS has stopped working" error when starting TruClient IE script in LR12

I turned off the  IE ESC for both user and administrator.   I was able to get the IE pages to launch, but when I stopped the recording I received the TCS Stopped Working error again and the script was not saved.

 

I have some more information.   The TruClient FF script was created successfully.  I was running it in vugen for 6 iterations.  They all worked fine, but after it finished I walked away for a few minutes.  When I returned the TCS error message was there.  Nothing was running on the server in vugen.

 

I ran the script in the controller with 10 vusers for 5 minutes.  The test ran successfully, but after the scenario finished the TCS error message appeared again.

 

Any thoughts??

 

Would V12.01 fix this problem?

0 Likes
Guy_Rosenthal Absent Member.
Absent Member.

Re: TCS has stopped working" error when starting TruClient IE script in LR12

Hi,

It sounds like another problem you have. Can you tell if you have some AV or other intrusive process running on this machine (such as Sophos)? If so, can you try to turn them off and retry?

 

Thanks.

Guy

Guy Rosenthal
Network Virtualization PM
0 Likes
Linda Marzik Respected Contributor.
Respected Contributor.

Re: TCS has stopped working" error when starting TruClient IE script in LR12

that was my 1st thought also ... I have double checked again.   Only windows processes, Virtual Clone Drive, VMware Tools, LoadRunner, and RDP Clip Monitor

 

there is a csrss.exe running ... this can be a windows process or a trojan ... but have had no issues on this server besides the LR TC IE problems.   Have 2 other servers for LR and it has this process running also.

 

Have double checked in Control Pannel ... only software installed is:

FileZilla

LR

LINQPad

MS .NET framework

MS Visual C++

MS WSE

VirtualCloneDrive

VMWare Tools

 

it is a clean minimal server.

0 Likes
Linda Marzik Respected Contributor.
Respected Contributor.

Re: TCS has stopped working" error when starting TruClient IE script in LR12

tried another server and it records fine in TC IE ... will compare all the settings

 

Will let you know what I find.

0 Likes
Linda Marzik Respected Contributor.
Respected Contributor.

Re: TCS has stopped working" error when starting TruClient IE script in LR12

I was able to record and save 1 time.   Have not been able to repeat the process.

 

It appears it is the disconnect of vugen from the browser that is causing the error.

 

After I was able to save the script the 1 time ... I did a replay.  When the replay failed, it gets the TCS Stopped working error and closes the "Develop Script" session.

When I select the "Develop Script" button again, I get the error stating:

HP Virtual User Generator

A communiction error occurred between the TruClient browser and Vugen.  Close the TruClient broswer if it is open and click the "Develop Script" button to restart the TruClient browser.  If the browser is already closed, restart VuGen.

 

When in Develop Script and the replay is successful.   I get the TCS Stopped working error when the script is complete.

 

Any clue on this disconnect error?

0 Likes
STSM Absent Member.
Absent Member.

Re: TCS has stopped working" error when starting TruClient IE script in LR12

Good day to all,

Could you please give an update whether you have solved the issue and how?

 

I have also experienced this behavior.

I have successfully created VUGen scripts in the past with IE true client  but as of now I only get the error that says TCS has stopped working and I am prompted to close the program.
When I try to replay the old Scripts

 

I have tried killing some unnecessary processes, restarting the machine. I have used a LR installation in my local machine (Win7 - IE 11 and FF 31 ESR) as well as a LR installation in a NATed environment (Win Server 2008 R2 - IE 9 and FF 31 ESR - NO Antivirus or Additional Protection Softare is installed ).
I am using LR - VUGen 12.02. build 2739

 

Thanks a lot in advance,

 

Silvi

0 Likes
AKhatake Absent Member.
Absent Member.

Re: TCS has stopped working" error when starting TruClient IE script in LR12

I am also getting same issue, Please update if anyone know any solution, I tried reinstallaing LR but no luck.

0 Likes
Absent Member.. NeilChikode Absent Member..
Absent Member..

Re: TCS has stopped working" error when starting TruClient IE script in LR12

I had the TCS stopped working issue starting last week after a security update for MIcrosoft Windows was installed.  HP support advised that I remove the security update KB3038314 and reboot.  This resolved the issue.

0 Likes
Suresh_G Absent Member.
Absent Member.

Re: TCS has stopped working" error when starting TruClient IE script in LR12

I removed KB3038314 and rebooted but issue still persists.

I am using Windows 2008 R2 server as LG.

Script recorded on LR12

VUgen version on LG 12

Controller version 11.52

 

Please let me know if there is any other solution to this problem.

 

Thanks,

Suresh


 

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.