Highlighted
Respected Contributor.
Respected Contributor.
1068 views

Terminal Services Issue

Jump to solution

Hi,

We are trying to use the Terminal Services’s LoadRunner functionality in order to avoid the limit GDI objects per Windows session in protocol SAPGUI. We have two types of servers; one of them is from which we execute the Controller Scenario, and the rest of them are injectors’ servers, which really execute the load against SAP ERP.

When we try to use Terminal Services from appropriate window tab in LoadRunner Controller, we select “Enable Terminal Services Manager”, number of terminals e.g. 2 and create new terminal services sessions.

We have activated checkbox “Enable Terminal Services” out of LoadRunner Controller in “Agent Configuration” too, and ran agent as a process. Once here, we press “Ok” to launch terminal services, and RDP is launched to start the connection with the injector server, but the following error message is shown:

“The initial application you are trying to open is currently unavailable. Contact your administrator to confirm that the correct settings are in place for your client connection.”

Note that we have administrator rights and else, so we don’t know why we can’t start the Terminal Services.

OS Revision: Windows 2008 R2
Product Version: 12.53

Kindly help.

Thank you in advance.

0 Likes
1 Solution

Accepted Solutions
Highlighted
Respected Contributor.
Respected Contributor.

Hi Eyal,

Thank you very much for your swift response.

I did find this in another discusssion mentioned below, which contains the latter mentioned 

/t5/LoadRunner-Practitioners-Forum/Loadrunner-Controller-with-terminal-session-mode/m-p/6956139/highlight/true#M21153

i'm troubleshooting as suggested, will update here as soon possible.

View solution in original post

0 Likes
2 Replies
Highlighted
Honored Contributor.
Honored Contributor.


Hi,

Have you tried running the agent as a service before changing it to run as a process?
Are you familiar with the information in the blog at: /t5/LoadRunner-and-Performance/Enhancing-the-number-of-TruClient-Vusers-using-Terminal-Services/ba-p/6897517#.V9UfWfl96Uk?
It show the settings required for using terminal services feature.

Regards,
Eyal

Highlighted
Respected Contributor.
Respected Contributor.

Hi Eyal,

Thank you very much for your swift response.

I did find this in another discusssion mentioned below, which contains the latter mentioned 

/t5/LoadRunner-Practitioners-Forum/Loadrunner-Controller-with-terminal-session-mode/m-p/6956139/highlight/true#M21153

i'm troubleshooting as suggested, will update here as soon possible.

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.