Highlighted
Contributor.. Contributor..
Contributor..
136 views

TruClient Chromium is not recognizing authentication prompt

Hi guys,

I´m dealing with some strange behaviour using a TruClient script. I have devenloped a TruClient script with TruClient Browser emulation which is working fine in the beginning.

Knowing, TruClient Browser is based on Firefox, i wanted to change the browser to Chromium as the web application I´m developing the script for is optimized for Google Chrome.

At the beginning of the test and the "normal way" users work, they get redirected 3 times and have to authenticate each time in a integrated authentication prompt.

 

In the test with TruClient browser the script development has recognized each of the authentication promts, so everything went fine.

After switching to Chromium, the last authentication prompt is not recognized by the script.

Even with a new script record, I cannot add the authentication step for the last authentication prompt. The VuGen TruClient editor is just not giving any recognition to the authentication prompt. It´s a normal browser integrated prompt and has the same behavior than the 2 before.

 

Does anyone has an idea why it is not possible to integrate this last authentication box in the Chromium browser?

 

Many thanks in advance!

Best regards

 

 

Labels (1)
0 Likes
3 Replies
Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: TruClient Chromium is not recognizing authentication prompt

Hi @LF_HV ,

Could you please upload the relative script for help us investigate the root cause? If your website is not public accessable could you please capture the network traffic with fiddler with https enabled. If none of these two could  be done please open a CPE case to let us investigate the root cause. 

Best regards,

Edwin

0 Likes
Highlighted
Contributor.. Contributor..
Contributor..

Re: TruClient Chromium is not recognizing authentication prompt

Hi @Edwin 

 

thanks for your reply.

We followed your advice and opened a support request.

Posting the script and traces is not an option as it is for internal purpose.

Best regards.

 

0 Likes
Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: TruClient Chromium is not recognizing authentication prompt

Hi @LF_HV ,

No problem. Thank you for you feedbacks. 

Best regards, 

Edwin

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.