Highlighted
Regular Contributor.
Regular Contributor.
249 views

TruClient Chromium plugin is not loading on VuGen

Hello All

I am having a hard time to use the TruClient on VuGen 12.62 version.

The problem is a problem with the plugin, I think. In simple terms, when I select Chromium option to record, the browser opens, but the truClient panel is missing. Looking into the console, there are errors. If I close the browser, VuGen reports an error.

I already tried to reinstall VuGen, but the error continues. In contrast, the IE option works.

Any clue on what´s going on? I attach the errors observed in the console of Chromium and the error on VuGen. 

Errors on the Console of ChromiumErrors on the Console of ChromiumError on VuGenError on VuGen

 

0 Likes
8 Replies
Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: TruClient Chromium plugin is not loading on VuGen

Hi @Ageo ,

It seems the communication between TruClient and VuGen is blocked. Here are two way worth to try. 

1. Start the VuGen as Administrator and try to launch Chromium again. 

2. Please follow this link and go throw the steps 

If all these attempts  are not works please let me know. Thank you.

Best regards, 

Edwin

0 Likes
Highlighted
Regular Contributor.
Regular Contributor.

Re: TruClient Chromium plugin is not loading on VuGen

Hi Edwin

Thank you for your input. Well,  I already saw that thread before. I tried to rename the json configuration but only refreshes the history of the scripts on LR. I am logged with admin priviliges and still, I cannot make this work. Curiously, the IE works.

Also, I tried with the TruClient version of Firefox and happens exactly the same. Only opens the browser but no panel of actions. I attach you the console log, maybe it can shows what is going on.

Let me know your thoughts.

Thank you in advance!

 

0 Likes
Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: TruClient Chromium plugin is not loading on VuGen

Hi @Ageo ,

Thank you for your feedback. It seems for some reason the communication between TruClient and ExtServer is block. TruClient uses the address 127.0.0.1 to communicate between the ExtServer. Is it restricted in your local environment? 

Does your VuGen is installed from a clean environment or upgrade from previous versions? The other possible reasons may be some of the setting files are corrupted. When this happens we need to check cases by case. 

Best regards, 

Edwin

0 Likes
Highlighted
Regular Contributor.
Regular Contributor.

Re: TruClient Chromium plugin is not loading on VuGen

Hi @Edwin 

Is there a way to review the first option (the block of the address of localhost) regarding the truClient? Like try to start or reach the service outside the IDE of VuGen?

Also, for the other point, yes, I have to downgrade due to license restrictions. I installed 2020 version and I had to unistall it and put 12.62 one. Is there something I can to do to review any conflict?

Thank you for your solid help!

0 Likes
Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: TruClient Chromium plugin is not loading on VuGen

Hi @Ageo ,

I'm trying to reproduce your issue locally. Will update the result to you soon. Thank you.

Best regards,

Edwin

0 Likes
Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: TruClient Chromium plugin is not loading on VuGen

Hi @Ageo ,

After installed 2020, uninstall and reinstall 12.62 the issue is not reproducted. 

The address can be checked from the commandline of Chromium after VuGen launched TruClient. Here is an example of the server information is 

ext_server_http_port=49201&-ext_server_https_port=49202&-ext_server_authentication_id=bfc6b58a-9b0a-4c6f-8664-5b79e3f75689&-cdp_port=49235

The server port will be 49201. Try to navigate to the address:port to see if it is blocked. 

Have you try to recreate a new script with VuGen. Is it OK? 

Best regards, 

Edwin

 

 

0 Likes
Highlighted
Regular Contributor.
Regular Contributor.

Re: TruClient Chromium plugin is not loading on VuGen

Hi @Edwin 

I tried your suggestions. Here is what I have:

1. The ports are different. Apparently, when Chromium loads, the ports in use are:

-ext_server_http_port=2540&
-ext_server_https_port=2541&
-ext_server_authentication_id=0e700c16-3424-4ddb-b821-3adf725c414c&
-cdp_port=2542

I attach you the full URL since I cannot paste it. I guess widget restrictions.

2. I tried to reach http://127.0.0.1:port with those ports and your suggestion. 2540 ends with "ERROR Empty Response". And the other, 49201, ends in blocked request.

3. In the case of the 2540, I reviewed with netstat if the ports were open and listening. In fact, I can see them establishing the connection when I trigger the hit. I attach you the screenshot. In the case of 49201 it does not even show in the list of netstat.

4. Regarding the recreation of VuGen. I can record with IE in TrueClient. It only fails with FF (TC Browser) and Chromium. Also, the web protocol  works without problems.

So, the port is open, but nothing is happening when I am hitting it.

Again, thank you very much for your support Edwin!

Regards

0 Likes
Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: TruClient Chromium plugin is not loading on VuGen

Hi @Ageo ,

We can also do additional steps to make sure this issue is a single environment issue or a common restriction to access 127.0.0.1:*.

Does any other machines in the same network environment can launch TruClientBrowser/Chromium successfully?

If you think it is necessary, you could open a CPE case for us to check the root cause. 

Best regards, 

Edwin

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.