Commodore Commodore
Commodore
732 views

[TruClient IE 12.53] Kerberos authentication

Jump to solution

Hi,

I'm facing an issue with the TruClient IE protocol on the last VuGen 12.53 (with patch 3).

When I try to record my application using Kerberos authentication, the TruClient IE browser ask me an authentication popup.

I found this KB stating to change the registry key "EnableNegotiate" to 1, but each time I open the TruClient IE browser with the "Develop script" button, this key is reset to 0!

How can I make this key to not change?

Thanks!

0 Likes
1 Solution

Accepted Solutions
Commodore Commodore
Commodore

Hi Daniela,

In fact I have found a simple solution : I edited the autorizations of the registry key to allow only administrator to change it. That way, the EnableNegotiate stays to 1 when the TruClient browser opens and the Kerberos authentication is running fine.

Thanks anyway for your post 🙂

Anyway, I still hope the enhancement request I submitted will be accepted! It's a shame we cannot set this setting in the runtime settings !

View solution in original post

4 Replies
Fleet Admiral
Fleet Admiral

Hello SylvainP31,

This seems to be a privileges issue. Are you using a full admin user? Have you tried opening the regedit by right click and runs as administrator?

Regards,

Daniela Gómez Alvarado
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
Commodore Commodore
Commodore

Hi Daniela,

Yes I opened regedit with full admin rights, but the problem still occurs.

Anyway, I opened a case to the support because currently this authentication setting can only be set globally on the machine, with this regedit trick. But I need to be able to set it at script level. Let's hope my request will have good reception from them.

0 Likes
Fleet Admiral
Fleet Admiral

Hello SylvainP31,

I'm just doing a follow to the thread. I know that you have a support ticket for this concern, and I was checking with my team some suggestions for this:

1.

Go to HKEY_CURRENT_USER\Software\Hewlett-Packard\TruClient\TruClientIE\TCWindows\CurrentVersion\Internet Settings\Zones

Registry key: 1A00 was set to 0 in all zones (0,1,2,3,4)

2.

Set to 0 the following registry key: HKEY_CURRENT_USER\Software\Hewlett-Packard\TruClient\TruClientIE\TCWindows\CurrentVersion\Internet Settings and Change "EnableNegotiate"

3.

 

  • Go to HKEY_CURRENT_USER\Software\Hewlett-Packard\TruClient\TruClientIE\TCWindows\CurrentVersion\Internet Settings\ZoneMap\Domains

 

  • Create two new keys: com\www
  • Create a REG_DWORD key named http or https depending of the application with value: 00000002 into www

 

Example:

Regards,

Daniela Gómez Alvarado
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
Commodore Commodore
Commodore

Hi Daniela,

In fact I have found a simple solution : I edited the autorizations of the registry key to allow only administrator to change it. That way, the EnableNegotiate stays to 1 when the TruClient browser opens and the Kerberos authentication is running fine.

Thanks anyway for your post 🙂

Anyway, I still hope the enhancement request I submitted will be accepted! It's a shame we cannot set this setting in the runtime settings !

View solution in original post

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.