Highlighted
Outstanding Contributor.
Outstanding Contributor.
659 views

TruClient Web, TLS/SSL error in IE only ...

Jump to solution

Working with a script I've been using for months (LR 12.5). For some reason it works fine in FF and Chromium. But when I try to run in IE (this machine has IE11) I get this message every time now:

This page can’t be displayed
Turn on TLS 1.0, TLS 1.1, and TLS 1.2 in Advanced settings and try connecting to https://swi1.MyWebSite.com again. If this error persists, contact your site administrator.

I've tried toggling all of the SSL options in the TruClient settings. Any ideas?

Thanks,

Chris

 

0 Likes
1 Solution

Accepted Solutions
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: TruClient Web, TLS/SSL error in IE only ...

Jump to solution

Hi,

I assume you are able to navigate successfully to the application using regular IE browser. 

What is the TLS version configured in it?

Maybe you need to add the site to the trusted sites list. It might help.

If needed contact HPE support team for help

Regards,

Shlomi

View solution in original post

3 Replies
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: TruClient Web, TLS/SSL error in IE only ...

Jump to solution

I would confirm the exact version of SSL that LR sees from the website, and select that one only. Website below describes how to use a tool HP provided with LR.

http://softwaretesttips.com/2013/10/11/how-to-find-the-ssl-version-and-cipher-type-used-by-a-secure-website/

 

You say that you now get an error, Did it work and has it stopped? Check if anything new has been implemented on your firewalls?

Have you tried on another machine (drone?) incase it is an issue with your IE11.

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: TruClient Web, TLS/SSL error in IE only ...

Jump to solution

Hi,

I assume you are able to navigate successfully to the application using regular IE browser. 

What is the TLS version configured in it?

Maybe you need to add the site to the trusted sites list. It might help.

If needed contact HPE support team for help

Regards,

Shlomi

View solution in original post

Highlighted
Outstanding Contributor.
Outstanding Contributor.

Re: TruClient Web, TLS/SSL error in IE only ...

Jump to solution

Thanks, Shlomi. The support team thinks it's an SSL bug in TruClient. It works fine in IE outside of VUGen. They offered a patch I'll try when I have a chance.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.