Highlighted
New Member.
1206 views

Truclient - Support for newer browser versions

Hi HP Support,

I have hit a compatibility issue attempting to record a script because the javascript used on the page was not supported by Chrome and Firefox versions because their versions are old (around 1 year and half old). I have found a workaround for that but that made me thing about the risk of having a tool supporting browsers version so old.

Maybe you can help me to assess that risk clarifying those points for Truclient protocol:

- is there any specific criteria behind the update ofTruclient supported browsers?

- when is it scheduled the next release providing support for more recent browsers and which version of the browsers will they be?

Thanks,

Camillo

4 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Truclient - Support for newer browser versions

Hi Camillo,

Which version of LoadRunner do you use?

We are trying to update Firefox and Chromium versions in each release of LoadRunner and pushing for the latest version possile on each of them. There are exceptions for that whenever the browser vendor breaks compatibility and then it takes a bit longer to get closer to the  recent version.

Regards,

Shlomi

 

0 Likes
Highlighted
New Member.

Re: Truclient - Support for newer browser versions

Hi Shlomi,

I am using LR 15.3. The error I got in Chrome is:
> Uncaught SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode

and it is caused by a JS function using the "let" construct to instantiate variables outside of the strict mode, which apparently both Chromium and Firefox version in LR 15.3 are not supporting yet:

function ExampleFun(var1) {
    if (var1) {
       let a = array[var1];}
}

 

Are you able to indicate roughly when next Truclient version will be released (like this semester or next semester)?

Thanks,

Camillo

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Truclient - Support for newer browser versions

Hi Camillo,

I understand...

I will forward this thread to additional subject matter experts. Maybe they will have an idea ow to overcome it

Unfortuntaely, according to HPE policies  i am not allowed to share dates, not even roughly. We share all data with customers who signed an NDA.

Regards,

Shlomi 

0 Likes
Highlighted
Outstanding Contributor.
Outstanding Contributor.

Re: Truclient - Support for newer browser versions

Hi Camillo,

the "let" directive is part of EcmaScript 6, supported in the latest browsers.

According to this availability matrix, it is partially supported in IE11, so as a workaround, you can try running the script inTruClient IE flavor.

I hope more updated broswers will be updated in the next release.

 

Edo

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.