New Member.
207 views

Unable to Handle "sap-hash" value

Hello All,

While developing a SAP script I noticed a sap-hash value appearing at Login request ,

Also I can see the same field 'sap-hash' under the response of home page ,but with value as NULL.

So here i need your help, I tried all possibilities of generating scripts, adding headers, and all whatever I could think.

Can you please suggest what can be done here ? Thanks !!

0 Likes
1 Reply
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Try to record your flow with help of a browser's development tools or with a tool like HTTPWatch. These tools will record everything and based on that you can conclude if your hash is generated by the server side or client side. When it is generated by the client side you have to check the LR API for SAP if there is a function to generate the hash, or else you have to identify the javascript code that generates the hash. You might be able to add that part of javascript code to your script.

A few year back I added javascript code for other application. I had to exchange information between javascript code and my C-script via LR parameters only.

P.S.

Did you try to highlight the hash value in VuGen en select 'correlate' via right mouse button click and see what VuGen can do for you?

Signature:
Reward community members who take time to respond and help.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.