Highlighted
Trusted Contributor.
Trusted Contributor.
154 views

Unable to See the request in proper format during replay

Jump to solution

Hi,

While recording the script we can see the request in below format in Snapshot.

GET /testpublic/en-us/public/signin.html HTTP/1.1
Host: test.test.com
Connection: keep-alive
Upgrade-Insecure-Requests: 1
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.130 Safari/537.36
Sec-Fetch-User: ?1
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3;q=0.9
Sec-Fetch-Site: none
Sec-Fetch-Mode: navigate
Accept-Encoding: gzip, deflate, br
Accept-Language: en-US,en;q=0.9

 

During the replay i can see the request as  

:method: GET
:scheme: https
:path: /testpublic/en-us/public/signin.html
:authority: test.test.com
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.132 Safari/537.36
Accept-Encoding: gzip, deflate, br
Accept-Language: en-US,en;q=0.9
Accept: */*

Any idea how can i see the request as i can see in recording mode. Due to this the response format is getting changed. (Only the format, not the content of the response)

Labels (3)
0 Likes
1 Solution

Accepted Solutions
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Unable to See the request in proper format during replay

Jump to solution

Hi,

Probably replay uses HTTP2 protocol for communication, thus request headers presented in the appropriate format.

You can disable HTTP2 features in RTS (Internet Protocol > Preferences > HTTP > "Enable HTTP/2 features" checkbox).

This option is available at least from LR 12.62.

Regards,

Leonid

 

View solution in original post

3 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Unable to See the request in proper format during replay

Jump to solution

Hi,

Probably replay uses HTTP2 protocol for communication, thus request headers presented in the appropriate format.

You can disable HTTP2 features in RTS (Internet Protocol > Preferences > HTTP > "Enable HTTP/2 features" checkbox).

This option is available at least from LR 12.62.

Regards,

Leonid

 

View solution in original post

Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: Unable to See the request in proper format during replay

Jump to solution

Agree with Leonid.

:method: GET
:scheme: https
:path: /testpublic/en-us/public/signin.html
:authority: test.test.com

are http2 headers while your recording is based on http/1.1.

 

One more comment, it's not LoadRunner but your server selected http2.

LoadRunner just said both "h2" and "http/1.1" were supported when connecting server. Your server answered "h2", so LoadRunner send http2 headers in request.

If you check off RTS > Internet Protocol > Preferences > HTTP > "Enable HTTP/2 features", LoadRunner will only send "http/1.1" request.

 

Regards,

Wei-Wei Zhang

 

0 Likes
Highlighted
Trusted Contributor.
Trusted Contributor.

Re: Unable to See the request in proper format during replay

Jump to solution
Thanks, as mentioned by Leonid. I am able to see the HTTP/1.1 after disabling the HTTP/2 features in RTS
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.