Highlighted
Frequent Contributor.
Frequent Contributor.
6074 views

Unable to execute/replay Java VUser script...Class path and Java/JDK requirements for VUGEN 11.50 ?

Hi 

I am using VUGEN 11.50, I tried to create Java VUser, and tried to execute... I got below error

Error: Failed to find javac.exe Java Compiler in Path and JDK installation folder in registry. Error: Failed to find java.exe. Please add the \bin to the path and try again. Warning: Extension java_int.dll reports error -1 on call to function ExtPerProcessInitialize Error: Thread Context: Call to service of the driver failed, reason - thread context wasn't initialized on this thread.

 

Please help me what should I do in terms of configuration  to run Java program in VUGEN

0 Likes
6 Replies
Highlighted
Absent Member.
Absent Member.

Hello,

Make sure you have Java 1.7 (or 1.6) JDK x32 installed.
Go to RTS, “Java VM” option, “Use the specified JDK” and add the path to Java 1.7/6 x32 JDK
Or (as an alternative to previous step) add a paths to directory that contains “jvm.dll” and to directory that contains “javac.exe” into PATH environment variable.

Thanks, Dmitry

0 Likes
Highlighted
Frequent Contributor.
Frequent Contributor.

Thank you Dmitry...  I have instealled JDK 1.7 ( 32 bit ) in Program File x86\Java\JDK....\bin..

 

Its not clear where this PATH element should be set .... I am using Windows 64 bit , 

 

I tried to set Path in Envrionment variables... but not sucessfull..

 

Now VUGEN says 'Cannot start replay due to compilation errors'... not sure... what to fix now.. please advise

0 Likes
Highlighted
Frequent Contributor.
Frequent Contributor.

In the OUT of VUGEN I see these errors... it complains about Javac.exe... but in that directory javac.exe is present...

 

Error: Cannot locate javac.exe under the specified C:\Program Files (x86)\Java\jdk1.7.0_79\bin JDK HOME directory.                [MsgId: MERR-22967]

Notify: Found jdk version: 1.7.0.               [MsgId: MMSG-22986]

Warning: Warning: Classpath entry not found: c:\jdk1.7.0_79\ojdbc7.jar;

Warning: Failed to find Classes.zip entry in Classpath.

                [MsgId: MWAR-22986]

Notify: classpath=C:\LoadRunner\Sample-Java VUser Script\;c:\program files (x86)\hp\virtual user generator\classes\srv;c:\program files (x86)\hp\virtual user generator\classes;C:\jdk1.7.0_79\ojdbc7.jar;C:\app\product\11.2.0\client_1;C:\OracleATS\oxe\app\oracle\product\10.2.0\server\bin;C:\oracle\product\10.2.0\client_1\bin;C:\windows\system32;C:\windows;C:\windows\System32\Wbem;C:\windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Enterprise Vault\EVClient\;C:\Program Files (x86)\Skype\Phone\;C:\Program Files (x86)\HP\Virtual User Generator\strawberry-perl\perl\bin;;;;c:\program files (x86)\hp\virtual user generator\lib\xstream-1.3.jar;c:\program files (x86)\hp\virtual user generator\lib\xpp3-1.1.4c.jar          [MsgId: MMSG-22986]

Notify: Path=C:\Program Files (x86)\HP\Virtual User Generator\Bin;C:\Program Files (x86)\HP\Virtual User Generator\Bin\tulip\bin;C:\app\product\11.2.0\client_1;C:\OracleATS\oxe\app\oracle\product\10.2.0\server\bin;C:\oracle\product\10.2.0\client_1\bin;C:\windows\system32;C:\windows;C:\windows\System32\Wbem;C:\windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Enterprise Vault\EVClient\;C:\Program Files (x86)\Skype\Phone\;C:\Program Files (x86)\HP\Virtual User Generator\strawberry-perl\perl\bin      [MsgId: MMSG-22986]

Notify: VM Params: .      [MsgId: MMSG-22986]

Error: Java VM internal error:Error Loading javai.dll.

.               [MsgId: MERR-22995]

0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Hi,

Please set the Home , Path and Classpath in the environment variables properly.

 

1) Set Home for JDK bin directory.

2)Set PATH=C\:JDK\bin;C:\LoadRunner\bin;C:\JDK\jre\bin\client(Example)
3)Set CLASSPATH=C:\LoadRunner\classes;C:\LoadRunner\classes\srv;C:\JDK\jre\lib\rt.jar(Example)

 

Also verify Compilation error http://lrhelp.saas.hpe.com/en/latest/help/WebHelp/Content/VuGen/137800_c_java_run_java_scpt.htm

Regards,

Raghul M

 

0 Likes
Highlighted
Respected Contributor.
Respected Contributor.

i have done same but my errors are still there.i got below errors in vugen.

rror: search current JDK in Windows registry at(SOFTWARE\JavaSoft\Java Development Kit) [MsgId: MMSG-22198] [MsgId: MERR-22986]
Error: search in JAVA_HOME [MsgId: MMSG-22197] [MsgId: MERR-22986]
Error: JDK found at C:/Program Files/Java/jdk1.8.0_211, but can not load jvm.dll(jvm.so) from C:/Program Files/Java/jdk1.8.0_211/jre/bin/server/jvm.dll. [MsgId: MMSG-22193] [MsgId: MERR-22986]
Error: Expect 32-bit JVM. To enable 64-bit JVM, please specify the JDK path in the "Runtime Settings"->"Java VM" and select the check-box: "Miscellaneous"->"Replay script with 64-bit" accordingly. [MsgId: MMSG-22192] [MsgId: MERR-22986]
Error: search in PATH [MsgId: MMSG-22197] [MsgId: MERR-22986]
Error: JDK not found [MsgId: MMSG-22199] [MsgId: MERR-22986]
Warning: Extension java_int.dll reports error -1 on call to function ExtPerThreadInitialize [MsgId: MWAR-10485]
Error: Vuser failed to initialize extension java_int.dll. [MsgId: MERR-10700]
-------------------------------------------------------------------------------

0 Likes
Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

The error shows your JAVA_HOME set to "C:/Program Files/Java/jdk1.8.0_211" which is 64bit, you can  enable 64-bit JVM by  selecting the check-box in Run Time Setting: "Miscellaneous"->"Replay script with 64-bit" .

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.