Highlighted
Absent Member.
Absent Member.
727 views

Unable to record mobile protocol using 12.50V Vugen

we are trying to record a mobile application using HP-load runner. And getting below error messages.

Can you please suggest here.

 

Steps followed for mobile recording:-

  1. Installed proxy.cer on both laptop and device
  2. Configured same WI-FI on both laptop and device
  3. Configured WI-FI IP address to device

 

Error messages:-

[API Trapper      (1efc:1fec)] Recording in 32-bit mode: C:\Program Files (x86)\HP\LoadRunner\bin\HP.LR.ProxyRecorderStarter.exe

[Network Analyzer ( 4b4:2090)] ------------------------------------------------------------------------------------------

[Network Analyzer ( 4b4:2090)] Load Network Traffic Analyzers:

[Network Analyzer ( 4b4:2090)]     Analyzer Module: WPLUS (value=)

[Network Analyzer ( 4b4:2090)]     Analyzer Module: WebBase (value=GetHttpProtocolAnalyzer:api_http_filter.dll)

[Network Analyzer ( 4b4:2090)]     + Network Analyzer: api_http_filter.dll @ GetHttpProtocolAnalyzer Loaded!

[Network Analyzer ( 4b4:2090)]     + Interception Auditors: WinInetWplusInterceptionAudit:api_http_filter.dll

[Network Analyzer ( 4b4:2090)]     Analyzer Module: Mobile (value=GetWebSocketProtocolAnalyzer:WebSocketAnalyzer.dll)

[Network Analyzer ( 4b4:2090)]     + Network Analyzer: WebSocketAnalyzer.dll @ GetWebSocketProtocolAnalyzer Loaded!

[Network Analyzer ( 4b4:2090)]     Analyzer Module: local_server (value=)

[Network Analyzer ( 4b4:2090)] ------------------------------------------------------------------------------------------

[Proxy Recording  ( 4b4:2090)] Started proxy on port 8080 in synchronous mode

[Proxy Recording  ( 4b4:2354)] Client request from @ 10.195.172.14:52333

[Proxy Recording.Error ( 4b4:1224)] Cannot establish a secure connection to the client, message=A call to SSPI failed, see inner exception.

 

Can you please suggest here.

 

Note: I followed 100% steps as mentioned below.

/t5/LoadRunner-and-Performance/Use-Proxy-Recording-in-LoadRunner-11-52-for-Mobile-Applications/ba-p/6152483

 

0 Likes
2 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Unable to record mobile protocol using 12.50V Vugen

Hi 

SSPI related messages are usually related to security & permission issues.

I suggest the following:

  • Verify you are running Vugen as an Administrator (i.e. right click -> Run As Administrator)
  • Verify there is no FW rule that is preventing outbound access from the Vugen machine
  • Try recording a different application and see that recording works
  • If that also fails, and you are running on an Android OS, consider using tPacketCapture application to create a pcap file and convert it later on to a Vugen script.

Good Luck,

Lior

Highlighted
Absent Member.
Absent Member.

Re: Unable to record mobile protocol using 12.50V Vugen

Thanks for your time to reply. 

I tried running as admin and I am getting an error message

"exception is caught during proxy start, message=Only one usage of each socket address (protocol/network address/port) is normally permitted"

 

Currently, I am trying to record in fiddler. Still not able to record the same. 

Device:- IOS

Thanks,

Kannan

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.