Highlighted
Absent Member.
Absent Member.
6309 views

VUGen-RTE Protocol-TE_Connect Question

I recorded a TE session using VUGen RTE Protocol. The issue is as follows:
While running the script opens the Power Term window and will not connect. Once I press enter, the script starts running fine. Is there a way for the script to strt running without me pressing 'Enter' on the power term window. Attached is the script and Application screenshots.
I tried placing TE_type("");
after the TE_Connect statement. It did not help. Any help is appreciated.

 

 

P.S. This thread has been moved from LoadRunner / Performance Center / StormRunner Load to LoadRunner Support Forum. - Hp Forum moderator

0 Likes
31 Replies
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: VUGen-RTE Protocol-TE_Connect Question

It seems you have not configured correctly.

vt420-7 may not be the right terminal type, so the reason you might be having this issue. Verify if it is working with selecting IBM 3270 Display type emulations solves Ur issues.

Go to Terminal >>> Setup >>> Select 3270 Display under IBM Terminals.

And do you have any proxy for connecting to this server ? in such case you neeed manually input the web_set_user()

Try all this & let me know output. I can help you.

-Raj

Regards,
Raj

Like this Post? Click Kudos! to show appreciation.
Is your issue addressed? Click "ACCEPT AS SOLUTION" against the post which helped you the most.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: VUGen-RTE Protocol-TE_Connect Question

Raj,
Thanks for responding. I tried with 3270 with no luck. Nothing shows up. The screen is idle. We are not using any proxy for this connection. Do not know, what else, I could be missing. HP was not of much help. They say SSH is not supported and sent me a few articles that not of much help.

-Raghu
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: VUGen-RTE Protocol-TE_Connect Question

Hey,

Why SSH came into picture ? It should be Telnet on port 7345. Do a manual telnet from the machine from which you are recording to server on the port 7345. See how it is behaving.

Do you have any authentication part in this script, as I dont see any here in this attachment.

There is nothing wrong with environment I believe. Did you happend to test the same on different machine ? we can't expect things are so perfect from the tools. So need to cross verify if it is any local issue.

-Raj

Regards,
Raj

Like this Post? Click Kudos! to show appreciation.
Is your issue addressed? Click "ACCEPT AS SOLUTION" against the post which helped you the most.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: VUGen-RTE Protocol-TE_Connect Question

Raj,

Manual Telnet is working perfectly fine. I connect to the mainfrmae using Putty. Attached is the screenshot of SSH Authentication. I am able to connect with out any issues. Even recording is working fine. The issue is running the recorded script. Once I press enter as soon as the power term window opens, the script then runs without any issues. if I do not press anything, the script will time out.
-Raghu
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: VUGen-RTE Protocol-TE_Connect Question

Interesting,

If TE_type(""); is not working, did you tried TE_type(""); ?

I donot remember but it might work here with VT terminals. try once.

Regards,
Raj

Like this Post? Click Kudos! to show appreciation.
Is your issue addressed? Click "ACCEPT AS SOLUTION" against the post which helped you the most.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: VUGen-RTE Protocol-TE_Connect Question

Raj,

Tried TE_type("");
No luck.
I need to press enter before TE_Connect. Then the script connects adn everything works fine. But, system does not understand any command before TE_Connect. Even if I put a statement like: TE_type(""); before TE_Connect. The scripts error out saying:
vuser_init.c(19): Error: Attempt to call TE_type on a non connected terminal -- Aborting user.
-Raghu
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: VUGen-RTE Protocol-TE_Connect Question

Hi Raghu,

Did you got this code after recording using VuGen RTE Protocol? Most of the time we need to hard code the script in RTE Protocol. So I suggest you to manually change the parameters in TE_Connect function and check if that works.

I have pasted a sample code below:

TE_connect(
"comm-type = tn3270;"
"host-name = 171.160.88.1;"
"use-tn3270e-protocol = false;"
"security-type = unsecured;"
"r2l-screen = false;"
"terminal-type = 3270 display;"
"terminal-model = 3278-2 (24x80);"
, 60000);
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: VUGen-RTE Protocol-TE_Connect Question

Amar,
I tried with you TE_Connect changing the required parameters with no luck. I tried recroding with 3270 Display. It didn't work either.

-Raghu
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: VUGen-RTE Protocol-TE_Connect Question

While recording, before you enter anything I recommend matching your keyboard to the keyboard of the terminal you are trying to record against.

This should work. Let meknow
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: VUGen-RTE Protocol-TE_Connect Question

I verified that the Keyboard map is matching.

-raghu
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: VUGen-RTE Protocol-TE_Connect Question

ok. I am sure you have client installed on the maching you are recording.

on the Power term:

1) Click Communication
2) Click Connect
3) Select Terminal Type
4) Enter HostName
5) Enter LU Name
6) Port Number

you can find all these details in the clients install directory.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.