Highlighted
Outstanding Contributor.
Outstanding Contributor.
4042 views

VUGen telling me I need to install WSE to run Web Service script? ...

Jump to solution

Working on VUGen 12.55. Trying to create a script do do some SOAP calls.

I quickly see this in the log:
Starting action Action.
Action.c(6): Error: To continue, WSE2 and WSE3 must be installed on your machine. The setup programs for WSE2.0 SP3 and WSE3.0 are included in the [LoadRunner installation DVD]\lrunner\Common folder or can be downloaded from the Internet.
Ending action Action.

I've used web service scripts many times before and I don't think I've ever seen this message. Further, I believe WSE is quote old and was replaced by WCF a long time ago:
https://en.wikipedia.org/wiki/Windows_Communication_Foundation

Any ideas?

Thanks in advance

 

p.s. I see this:

https://softwaresupport.softwaregrp.com/km/KM02063108

But we already have .NET 4.7.1 installed and I'm not crazy about the idea of installing much older stuff over the top of that. 

0 Likes
1 Solution

Accepted Solutions
Highlighted
Outstanding Contributor.
Outstanding Contributor.

Re: VUGen telling me I need to install WSE to run Web Service script? ...

Jump to solution

Yes, WSE is still need.  In previous version it's probablly automatically installed as a part of LR.

As to WCF, yes it's supposed to replace WSE in Microsoft's strategy, but existing product can't migrate to it automatically without invest effort in rewriting almost everything.

View solution in original post

4 Replies
Highlighted
Outstanding Contributor.
Outstanding Contributor.

Re: VUGen telling me I need to install WSE to run Web Service script? ...

Jump to solution

Yes, WSE is still need.  In previous version it's probablly automatically installed as a part of LR.

As to WCF, yes it's supposed to replace WSE in Microsoft's strategy, but existing product can't migrate to it automatically without invest effort in rewriting almost everything.

View solution in original post

Highlighted
Outstanding Contributor.
Outstanding Contributor.

Re: VUGen telling me I need to install WSE to run Web Service script? ...

Jump to solution

Thanks, I appreciate it.

0 Likes
Highlighted
Frequent Visitor.

Re: VUGen telling me I need to install WSE to run Web Service script? ...

Jump to solution

My solution was to go to the folder in the message and run the two product installs again... and doing a repair on each.  After doing this my script ran fine.

0 Likes
Highlighted
New Member.

Re: VUGen telling me I need to install WSE to run Web Service script? ...

Jump to solution

HI All,

Currently i am also facing the same problem -need to install WSE 2 ans WSE 3 in your machine in vugen 15.55 and above.Please help on this how to fix it?

 

Whether i need to install WSE 2 and WSE 3 /?? or Any other solution is there??

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.