Highlighted
Absent Member.
Absent Member.
680 views

VuGen- recording HTTPS website

Hi,

we are trying to use VuGen to generate a load test script. the site is working on https and when trying to record, we get an ssl certificate error. we tried to change the default properties in 'record options' but this allow us to partial record the site ( after we manually approving the ssl certificate).

by partial recording I mean that the site dont render as expected and some elements are missing (images, iframes and more).

do you come across this kind of issue ??

Thanks,

liron

0 Likes
1 Reply
Highlighted
Honored Contributor.
Honored Contributor.

Re: VuGen- recording HTTPS website

Hi Liron,

I would start troubleshooting the problem in the following way:

1. Get wireshark trace of the application without LoadRunner to see the exact SSL version and Cipher used by the application (without LoadRunner recording).

2. Check if the application might be using several versions of SSL

3. Try to see if all is configured correctly in the port mapping dialog

If no issue or difference found check if I can generate a script from the captured content.

Please note that in LoadRunner 12.50 we support generating additional capture tools beside wireshark.

 

Oded

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.