Highlighted
Trusted Contributor.
Trusted Contributor.
235 views

VuGen v12.02 Flex Externalization READ-ONLY issue

Jump to solution

VuGen v12.02 Flex Externalization READ-ONLY issue in run time settings. unable to add JAR's or serializatino.

This is urgent please.

 

0 Likes
1 Solution

Accepted Solutions
Highlighted
Absent Member.
Absent Member.

Re: VuGen v12.02 Flex Externalization READ-ONLY issue

Jump to solution

There are two ways to change the jar files:

  1. Re-record the script, and include the new jar files in Recording Options dialog.
  2. Edit default.cfg file, which resides in the script library.

The relevant fields are in [Flex] region:

UseAdditionalJars=Yes

FlexJarFiles=here you can edit the files paths.

View solution in original post

8 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: VuGen v12.02 Flex Externalization READ-ONLY issue

Jump to solution

Hello apve03,

 

Please try open the VuGen by right click and run as administrator.

 

 

Regards,

Daniela Gómez Alvarado
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
Highlighted
Trusted Contributor.
Trusted Contributor.

Re: VuGen v12.02 Flex Externalization READ-ONLY issue

Jump to solution

Still the same READ ONLY mode. I opened the VuGen by right click and run as administrator.

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: VuGen v12.02 Flex Externalization READ-ONLY issue

Jump to solution

When the software was installed, did you installed it with a full admin account?

Regards,

Daniela Gómez Alvarado
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
Highlighted
Trusted Contributor.
Trusted Contributor.

Re: VuGen v12.02 Flex Externalization READ-ONLY issue

Jump to solution

Yes, I did the installation with full admin account.

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: VuGen v12.02 Flex Externalization READ-ONLY issue

Jump to solution

I was searching for more information about this, and unfortunately, this version of LoadRunner does not support to enable this option. But there is a workaround for trying to solve this:
-create a new flex script.
-add the jar files in the recording options.
-once recorded,  you need to edit the default.cfg file in the problematic script and enter the jar files copying them (you can change the path or and add rebuilt jar files) then, save it.

Regards,

Daniela Gómez Alvarado
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
Highlighted
Trusted Contributor.
Trusted Contributor.

Re: VuGen v12.02 Flex Externalization READ-ONLY issue

Jump to solution

1) We are trying to use VuGen v11.5 scripts in VuGen v12.02. 

2) If we want to update new project bulild Java JAR's its not letting to update.

 

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: VuGen v12.02 Flex Externalization READ-ONLY issue

Jump to solution

This behavior is by design. The idea is that the script should be replayed as it was recorded (or regenerated). If JARs will be added/removed there is more chance that replay will fail.

If you still need to change the JARs, you can manual edit it in defulat.cfg file.

 

Thanks,

Yoav

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: VuGen v12.02 Flex Externalization READ-ONLY issue

Jump to solution

There are two ways to change the jar files:

  1. Re-record the script, and include the new jar files in Recording Options dialog.
  2. Edit default.cfg file, which resides in the script library.

The relevant fields are in [Flex] region:

UseAdditionalJars=Yes

FlexJarFiles=here you can edit the files paths.

View solution in original post

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.