Highlighted
Absent Member.
Absent Member.
802 views

Vugen 12.02 unable to record on Citrix 7.6 Storefront with normal user

Hello,

When I record against citrix v7.6 using Vugen 12.02 I get the welcome page and then it disconnects.  This works fine with admin user however unable to connect to published app with normal user.

Any help to resolve this issue will be much appreciated.

Kind regards,

Addi 

0 Likes
3 Replies
Highlighted
Absent Member.
Absent Member.

Re: Vugen 12.02 unable to record on Citrix 7.6 Storefront with normal user

Hi Addi,

It is quite unclear what exactly your problem is.

1. If you are able to login to StoreFront, click on icon of published app and Citrix Client opens but shuts down immediatelly - then I'd recommend to install Citrix registry patch manually before recording.
Please find <LoadRunner>\dat\Enable_Citrix_API.reg file and apply it to your registry (note that on 64-bit operating systems these keys should reside under the HKLM\Software\Wow6432Node).

2. If Citrix Client doesn't even start when you're clicking on published app icon, try to disable DEP for you InternetExplorer and disable "Run ActiveX addons and plugins" under Tools->Internet Options->Security. (If Vugen is installed on Win2008R2 Server, you might additionaly need to disable IE ESC (Enhanced Security Configuration)).

 

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Vugen 12.02 unable to record on Citrix 7.6 Storefront with normal user

Hi Al_Hovan,

 

Thank you for your response much appreciate this.

I have now progressed a bit to the extent that i am able to launch published app via store front using loadrunner 12.53 against Citrix 7.6.

 

The problem I am facing now is that using the multi protocol web HTML/HTTP and Citrix I am unable to record any Citrix events.  After the generation of ctrx_nfuse_connect("https://storefront.uug.vcm.cc/Citrix/UUWeb/Resources/LaunchIca

When I click or tab around the citrix published app no events are recorded, I would have expected these to be recorded using muti protocol  web HTML/HTTP and Citrix, any assistnace would be much appreciated.

0 Likes
Highlighted
Contributor.. Contributor..
Contributor..

Re: Vugen 12.02 unable to record on Citrix 7.6 Storefront with normal user

Hi All,

I'm facing similar issue as well. i'm unable to record storefront traffic (Citrix Xenapp 7.X version) using vugen 12.53. 

when tried recording using multiprotocol (Citrix ica+ web http), no events are being recorded post the ctrx_nfuse_connect(); 

could any one suggest required settings to be done in order to capture the traffic...

kindly suggest.

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.