Highlighted
Regular Contributor.. Regular Contributor..
Regular Contributor..
1013 views

Vugen TruClient Firefox error: Activate browser window #2 ** failed

Hello all,

 

I have a script which includes clicking a link which launches a copy of an ID card which is a pdf.


I am using Vugen 12.02 and the Truclient FireFox protocol. The version of Firefox is 41.0.1. The script will play back succesfully in the Truclient interactive (Develop Script) window. However it fails with the error listed below when it is run from Vugen

 


   Error -205177: ** 12: Activate browser window #2 ** failed - runtime error:
   'Ordinal': The specified value (2) is invalid       Snapshot Info [MSH 1 0]    [MsgId: MERR-205177

 

 

Googling this error yields the suggestion to change the Firefox configuration, specifically set “disable_open_during_load”  to false.

these are the pertinent Firefox settings:


   dom.disable_open_during_load;false

and

   services.sync.prefs.sync.dom.disable_open_during_load;true

 


The first setting seems to be correct. Changing the second setting to false allows a script to record but the script will not paly back corerctly, even in the interactive Truclient session. I get the following error:

    Activate browser window #2 ** failed - runtime error: 'Ordinal': The specified value (2) is invalid

 

 

 

Any suggestions would be greatly appreciated.

Thanks,


Dave

0 Likes
2 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Vugen TruClient Firefox error: Activate browser window #2 ** failed

Hello Dave,

 

Can you please share a snapshot of the script steps, specifically in the area that fails?

 

Is a new window/tab being opened to host the PDF file? Did you try disabling the Activate Browser step and if so did it help?

 

Regards,

Shlomi

 

 

0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: Vugen TruClient Firefox error: Activate browser window #2 ** failed

Hello @Shlomi Nissim

I am having similar issue. I recorded FireFox browser using Truclient and my flow requries to click on Job# which opens up seperate browser(not tab) and rest of the activities need to be completed. BUt when i click on Job#, it shows 

"Activate browser #2 failed, window not found". Any suggestion on this?

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.