Highlighted
Absent Member.. Absent Member..
Absent Member..
65836 views

Vugen recording issue - Website's security certificate error

 

Hi,
I could not get around this, but why I am getting the security certificate error while Vugen recording - HTML/WEB Protocol - LR 9.5, IE7?And the blocked contents notification on below IE 7 tool bar - To help protect your security, IE has blocked this web site from displaying content with security certificate error. Click here for options ..,
Most annoying thing is while doing same thing manually (same web page, same machine and IE7), not getting this error!! I know there is some certification issue with the web page (which is going to live in few days), but that will be fixed once it is in prod. 
But wondering why I am getting this while vugen recording but not manually? Also I can not ask project team to install a valid certificate because I am getting error only thru Vugen.
Anybody has any idea how to by pass this while recording? Can't get anything from LR recording options  I just do not want it tho my script re-run fine (some sort) but it creates two web_url steps (for right click to see view blocked contents) and hell I can't even see the server responses in tree view .. LR can't show me page view, server response .. silly 
Please let me know your suggestions 
Cheers
Deb  

 

Thanks
Deb
Tags (1)
0 Likes
36 Replies
Highlighted
Absent Member.
Absent Member.

Re: Vugen recording issue - Website's security certificate error

My guess: you set an exception in your browser so you no longer see the message but vugen always starts from fresh.

 

But anyway, this is irrellevent to server request/response traffic - it's client side.

 

To make the world a cleaner better best practice kind of place you could ask for a global self-signed cert. accross all test servers. This won't cost the Earth and solves tne IE blocks me problem. But if you can still record your requests and playback if unaffected, and you are only interested in server responses, then you can safely ignore this issue.

 

Oliver
0 Likes
Highlighted
Established Member..
Established Member..

Re: Vugen recording issue - Website's security certificate error

Hi,

 

Could you please inform how you overcome this, I am also facing the same problem.

 

Regards,

kumaran dp

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Vugen recording issue - Website's security certificate error

Friends,

 

I am also facing the same issue. Please let me know how to resolve it.

 

Thanks in Advance

 

Warm Regards

Siva

0 Likes
Highlighted
Established Member..
Established Member..

Re: Vugen recording issue - Website's security certificate error

HI Solved this problem by reinstalling the Ie version from 8 to 7 and recorded the application with vugen 11. It got fixed my problem.

 

REgards,

kumaran dp

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Vugen recording issue - Website's security certificate error(Solved)

I am using Load Runner 11 and Windows Vista . I had this same problem and finally found a solution after spedning 3 days on it.

 

Solution that worked for me.

 

Go to Recording Options.On this window, select "Port Mapping" which is available under Network option

Now click on "Options" button which is available at the bottom right corner of Network > Port Mapping.

 

Another window called "Advanced Port Mapping Settings" will be displayed. On this window, uncheck the check box(default is checked) corresponding to "Enable auto SSL detection".Click Update button.

Now click OK button on Recording Options window.

 

Try to record script now and it should work with out any errors and no more website security certificate error.

 

Highlighted
Absent Member.
Absent Member.

Re: Vugen recording issue - Website's security certificate error(Solved)

The instruction to uncheck the checkbox selection for 'Enable auto SSL detection' under the Recording Options / Port Mapping / Options fixed this problem for me as well. I am using LoadRunner 9.52 and VuGen 9.52 with IE8 record enablement patch installed and now successfully recording via IE8. Thanks for the great info!

Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Vugen recording issue - Website's security certificate error(Solved)

I'm also experiencing the same problem with IE8, LR11 (patch 4), & Win 2003 SP2.  I made the changes to the port option and it didn't work. 

 

After disabling the option, I don't get the certificate error however Vugen is not recording any events.  Have anyone found another solution to overcome this problem?

 

Is this related to the new patch? Or is it a known issue in IE8?

 

Any suggestions appreciated.

0 Likes
Highlighted
Super Contributor.
Super Contributor.

Re: Vugen recording issue - Website's security certificate error(Solved)

the uncheck auto detect SSL worked for us.  we are using loadrunner 11.03 with IE 9.  on machines with IE 8 we did not have this issue.

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Vugen recording issue - Website's security certificate error(Solved)

Hi,

 

I am using http-sap protocol and I follow the same procedure but tool is unable to generate the script  but the events are recorded by the tool can you please tell me what oprtion should I use. I am using LR 9.52

 

Thanks

 

Akshat

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Vugen recording issue - Website's security certificate error

HI Raghavendra,

 

I am trying to generate the script using web(HTTP/html) & Flex protocals.But events not recorded when i tried to record..but it's working properly 2 days back. Please let me know the solution to solve this problem.

 

if open application by manually it's opening properly with out any issues.

 

Regards,

PRasad

0 Likes
Highlighted
Super Contributor.
Super Contributor.

Re: Vugen recording issue - Website's security certificate error(Solved)

The Disable option is worked, but when we do this even those the events count is increasing during recording, when we complete record and stop it is not generating any code. this is happening for the applications startng with https://

 

any idea how to slove this problme?

 

Anil

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.