Highlighted
Super Contributor.. Super Contributor..
Super Contributor..
120 views

Warning -27487: "web_set_sockets_option" has no effect on WinInet replay

Jump to solution

Since going to version 12.63 I have had to check the "Use Winlnet replay instead of sockets"  Preferences Advance Option.  This is the only way I can execute new or old scripts. By turning this on performing high load volumes I am seeing socket time out issues in my application's logs.  Does anyone have a workaround or idea how I can execute a script without checking the Winlnet option?

Boatnlarry
0 Likes
1 Solution

Accepted Solutions
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: Warning -27487: "web_set_sockets_option" has no effect on WinInet replay

Jump to solution

JHF Remmelzwaal,

Thank for your advise, unfortunately it didn't solve our error.  But, looking at other setting I was able to try a few things in the Authentication section. I Checked, Use the native Windows NTLM implementation and I Checked, Enable Integrated Authentication along with your change and error went away.  Also Uncheck, Wininet replay instead of sockets.

Boatnlarry

View solution in original post

0 Likes
3 Replies
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Re: Warning -27487: "web_set_sockets_option" has no effect on WinInet replay

Jump to solution

Just a wild guess, i.s.o. enable 'Enable WinInet' you might try to disable RTS -> Preferences -> HTTP -> Enable HTTP/2 features (disable in this case).

Our experience is that the option HTTP/2 gave unexpected behavior of scripts after upgrade to LR to 12.6x

Signature:
Reward community members who take time to respond and help.
0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: Warning -27487: "web_set_sockets_option" has no effect on WinInet replay

Jump to solution

JHF Remmelzwaal,

Thank for your advise, unfortunately it didn't solve our error.  But, looking at other setting I was able to try a few things in the Authentication section. I Checked, Use the native Windows NTLM implementation and I Checked, Enable Integrated Authentication along with your change and error went away.  Also Uncheck, Wininet replay instead of sockets.

Boatnlarry

View solution in original post

0 Likes
Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: Warning -27487: "web_set_sockets_option" has no effect on WinInet replay

Jump to solution

Hi @boatnlarry 

If you read the help file of web_set_sockets_option, you will find

"The web_set_sockets_option function configures options for sockets on the client machine. This function supports socket-level replay."

If you enable "WinInet replay" it's not "socket-level replay"

 

If you want "socket-level replay" and get issues, you can upload your scripts  and replaying logs.

 

Regards,

Wei-Wei Zhang

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.