Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..
644 views

Web Application Protocol HTTPS in Vugen 12.5x

Hello community,

I would like to get some feedback or advice on the web application that I am working on.

Currently, the application that I am working on is in an internally secured environment with no external traffic or access from in and out.

So far what I have noticed is that Vugen is not able to capture all of traffics between server and application.

Basically, when the homepage of application is loaded up then there is trace. However, after that no matter what functions are hit or executed by end user (like me recording), there is no trace at all.

I've played with HTML-based/URL-based script option, but they did not do much and help.

In a situation like this, what would be the possible tactic to record the script? Is it something security related or protocol related?

Thanks in advance.

0 Likes
7 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Web Application Protocol HTTPS in Vugen 12.5x

Hi @yangnigon,

I recommend trying one of the following options

1. Record the script via a proxy. See this help page for more details.
2. Generate a script using a PCAP file. It is usally being used for mobile applications, but it is not restricted to it.
3. Create a script using a SAZ or HAR files. See this help page for more details.

If you do not need to run many Vusers, you can try TruClient as an alternative.

Regards,
Shlomi

Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: Web Application Protocol HTTPS in Vugen 12.5x

Thanks Shlomi

I will try what you suggested and update my finding here.

Regards,

0 Likes
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: Web Application Protocol HTTPS in Vugen 12.5x

As promosied, here is an update.

1) I've tried this, but this did not help. I did not see any difference with this method.

2) This looks like you need to have network activity capturing tools such as Wireshark to complete it. I am currently in a secure environment and this software/tool is not permitted. (I can request and see what happens, but I am not that optimistic about this)

3)  Same reasons as above.

So this leaves me last option such as trying with TruClient as an alternative. Can you clarify what you mean by "if you do not need to run many Vusers"? Are you implying many business transactions or something else? Also, can this be done in IE instead of Firefox?

The web application that I am working on is embbeded with javascript, other technologies, and etc, perhaps this is why it's not liking VuGen's session recording?

Please let me know if you have other suggestation.

Thanks,

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Web Application Protocol HTTPS in Vugen 12.5x

Hi @yangnigon,

You can proceed with TruClient Web protocol and choose IE as the browser to work with.
I also suggest opening a support ticket to further investigate the Web (HTTP/HTML) recording issue. Our experts might find a solution by interacting with you.

Regards,
Shlomi

Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: Web Application Protocol HTTPS in Vugen 12.5x

Thanks Shlomi for your response.

I will try with TruClient and see if it makes sense to use it in this situation.

If none of them works as expected then I will open a support ticket to further investigate the web (HTTP/HTML) recording issue.

Thanks,

Highlighted
Contributor.
Contributor.

Re: Web Application Protocol HTTPS in Vugen 12.5x

Hi,

Having almost same issue...

When "socket level data" selected in 'Network: Mapping and Filtering' and "Enable auto SSL detection" selected in 'Advanced Port Mapping Settings'-- User failed to loging durign recording. But no issue when login manually.

Also-- able to login during recording IF "Enable auto SSL detection" UNCHECKED

Tried selecting almost all SSL version available like SSL2.x, 3.x  TLS 1.0, v1.1, v1.2

No certificate issue so far I think

Proxy settings done correctly

Any suggestion will be highly appreciated.

yangnigon... Please post if you open a ticket and get solution.

thank you in advance and regards

ajs

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Web Application Protocol HTTPS in Vugen 12.5x

Hi @asj,

Please share the recording logs here. It might help understanding the issue better.

Regards,
Shlomi

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.