Highlighted
Established Member..
Established Member..
599 views

lr_db_connect using informix

Hello,

I am trying to use the lr_db_connect command in VuGen 12.53 to connect to an Informix dB and run a query to create a parameter file dynamically during a test.  However, I can't seem to figure out how to setup the strings for my situation.  I saw a post (Connecting to DB2 using LoadRunner) that discussed how to do this for DB2, but I have been unable to find an example for Informix.  Using the example from the DB2 post I came up with:

lr_db_connect("StepName=myDbStep",
"ConnectionName=myConnection",
"ConnectionString=Driver={Informix ODBC DRIVER};Database=[MyDbNameHere];Hostname=[MyHostNameHere];Port=[MyPortHere]; Protocol=TCPIP;Uid=[MyUserNameHere];Pwd=[MyPasswordHere];",
"ConnectionType=ODBC",
LAST);

However, when I run the test - I get an error on this command:  

Action.c(75): DB Connection "myDbStep" started ... Wait ....
Action.c(75): DB Connection failed {"ERROR [IM002] [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified"}
Action.c(75): Error (-17940): DB Connection failed {"myDbStep"}

Any suggestions?

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.