New Ranks & Badges For The Community!
Notice something different? The ranks and associated badges have gone "Star Fleet". See what they all mean HERE
Highlighted
Absent Member.. Absent Member..
Absent Member..
1871 views

lr_set_transaction () not working on LoadRunner 12

Hi Friends,

 

I am working on a script where I need to manually set a transaction with a transaction time (ping response), but I see that the function lr_set_transaction is not working on CVuser protocol in LoadRunner 12. Please let me know if the function is supported for LoadRunner 12?

 

the syntax I am using is as below:

 

lr_set_transaction("new",12.13,LR.PASS);

 

any help is greatly appreciated.

0 Likes
15 Replies
Highlighted

Hi,

 

As your description, you are using 'LR.PASS' in the function.

The correct one is LR_PASS, so it it should be like this:

 

lr_set_transaction("new",12.13,LR_PASS);

 

Please try again and share the outcome.

 

Regards,

Chau Nguyen

Regards,

Chau Nguyen | SW Technical Support Consultant.
LoadRunner and Performance Center


If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Same Result, actually it was a typo in my post I did use an "_".

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Did anyone try this and was successfull, please share if you could because this is part of a critical implementation we have and I have almost reached my objective but this is not working 😞

0 Likes
Highlighted

Hi,

 

Could you please share your script?

 

Thanks and Regards,

Chau Nguyen

Regards,

Chau Nguyen | SW Technical Support Consultant.
LoadRunner and Performance Center


If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

I have attached the script here

0 Likes
Highlighted

Hi,

 

Please try to replay the modified script and share the result.

 

Regards,

Chau Nguyen

Regards,

Chau Nguyen | SW Technical Support Consultant.
LoadRunner and Performance Center


If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

I tried this but I get the error as :

Error: Vuser started transaction "Headquarters", but did not reached a corresponding end transaction statement. The transaction ended automatically with status 'fail'.

for both of my transactions, apparently this was the first thing I tried as well but it did not work 😞

 

is there any document which tells which functions which were carried forward from previous load runner versions and turned obselete?

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

As a favor, are you able to use the lr_set_transaction in a simple CVuser script on ur end? can you let me know if you are able to do so?

0 Likes
Highlighted

Hi,

 

Yes, I am able to use lr_set_transaction in a simple script in Vugen 11.52 and Vugen 12.00 as well.

Per your previous script, I see that you have 2 transactions : Regional and Headquarters. So you got the error only with 'Headquarters' transaction?

In your script, there are many functions 'lr_start_transaction' and 'lr_end_transaction', please check script again and make sure each  'lr_start_transaction' function has a corresponding end transaction statement.

 

Regards,

Chau Nguyen

Regards,

Chau Nguyen | SW Technical Support Consultant.
LoadRunner and Performance Center


If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Can I call you? I dont know why I am not able to use it, as per what I understand when I am using lr_set_transaction I do not need to use a lr_start_transaction. Am I correct? pls pm (personal message) me ur number I think we can resolve this better that way? some help here will actually aid me in putting through this critical implementation on my end 🙂

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Can you share the Loadrunner 12 script where you are using lr_set_transaction? I will compare for differences?

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.