Highlighted
Absent Member.
Absent Member.
8657 views

"No snapshots available" message on Loadrunner 12.53 VUGen

Hello

 

Using loadrunner HP VUG 12.53 Build 1203

 

My VuSer Script has an number of actions including web_submit_data. Right now, when I replay the script, nothing is returned to the 'Snapshot' pane when I double click on the step in the 'steps navigator'- it just displays 'No snapshots available'.

In Tools > Options > Scripting > Snapshots, the only option I have enabled is 'Enable snapshot viewing'. I tried enabling./disabling some of these but got an error 'Cannot set object reference to an instance..' type thing.

In Runtime Settings under Log, i have all the options ticked and 'Extended Log' selected except 'Print timestamp.. and in 'Miscellaneous' I have 'generate shapshot on error' selected. I also enabled 'Generate snapsots on replay' under the HTTP menu.

I'm aware some actions do not generate snapshots - I know that these snapshots were working previously and did work when I recorded the actions initially, so all this proves is that I was able to view some snapshots at one point!

 

0 Likes
15 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: "No snapshots available" message on Loadrunner 12.53 VUGen

Hi,

Can you please check the script run time settings and make sure that "Create snapshots during reply" is turned on. It can be found under Internet Protocol > Preferences > General section.

Regards,

Shlomi

 

0 Likes
Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..

Re: "No snapshots available" message on Loadrunner 12.53 VUGen

I have checked that option is turned on, yes.

 

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: "No snapshots available" message on Loadrunner 12.53 VUGen

It is hard to tell without actually seeing and replaying the script myself.

Some steps do not have snapshots since there is no data returned from the server. If this is not the case you should open a support ticket and get help

Regards,

Shlomi

0 Likes
Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..

Re: "No snapshots available" message on Loadrunner 12.53 VUGen

Strangely, it appears to have started working again - possibly closing and re-opening the app or restarting my computer resolved it. I was only hoping for it to work with specific actions - as I know some do not have the 'snapshot' available.

 

Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: "No snapshots available" message on Loadrunner 12.53 VUGen

Glad to hear it is working now.

BTW: I meant to write earlier "Maybe some of the steps do not have data returned from the server". I accidently omitted the "Maybe" 🙂

 

0 Likes
Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..

Re: "No snapshots available" message on Loadrunner 12.53 VUGen

It's not creating a snapshot for my web_custom_request now, even though it's successfully picking up the return using web_reg_find - getting the 'No Snapshots Available' message again. 

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: "No snapshots available" message on Loadrunner 12.53 VUGen

I will involve someone who is more knowledgable than I am on this matter

0 Likes
Highlighted
Outstanding Contributor.
Outstanding Contributor.

Re: "No snapshots available" message on Loadrunner 12.53 VUGen

Hi,

First of all, only vugen generated steps can have snapshot. That means, if you added those steps manually afterwards, there'll be no snapshot.

Let's assume these steps are indeed generated by VuGen. Then we should check whether it's a VuGen side issue or web replay issue. During replay, web engine will generate snapshot files on disk, and later VuGen will read these files and display them in snapshot viewer. So we should check whether these files generated.

Please go to "result1" under script's folder, open "results.xml" file. It's an index of all the generated snapshot during replay time. The actual snapshot files are under "iteration0" or "iteration1" folder. You can check whether your step is included in it, then update to us. Each step should have a <Step> node in results.xml and the "obj" node is the step name. Like below,

<Step rID="T6">
<Obj plainTxt="False" ><![CDATA[Submit Form: login.fcc]]></Obj>

 

Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..

Re: "No snapshots available" message on Loadrunner 12.53 VUGen

So there is no way of getting it to generate a snapshot if I have entered the step manually myself? That's a shame and a bit of a flaw of the product. I need to find out exactly what it's sending as the parameter for the 'request'. I can see the response body from the logs. I guess I will have to find another way of doing this - I will create a new post and ask for help directly with the issue I'm having.

 

0 Likes
Highlighted
Outstanding Contributor.
Outstanding Contributor.

Re: "No snapshots available" message on Loadrunner 12.53 VUGen

You can enable log for request in RTS. Of course, that might generate too many logs.

0 Likes
Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..

Re: "No snapshots available" message on Loadrunner 12.53 VUGen

Well I worked around it, in that I solved my problem without the snapshot working... Thanks for your help!

I learnt something new about correlation, so it's actually been useful in the end.

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.