Highlighted
Trusted Contributor.
Trusted Contributor.
679 views

"To" field is blank in the email sent from SMTP

We have a requirement to send email from loadrunner.

For the below code if I send the email, the "To" field is blank in the email.

    smtp_send_mail("SendMail",
        "To=receiver@abc.com",
        "Subject={Subject}",
        "From=sender@tbc.com",
        "ContentType=text/plain;",        
        "ContentType=application/pdf;", 
        "ContentType=multipart/mixed;",        
        "ContentDisposition=attachment;",
        "filename={P_Attachment}",
        "charset=\"iso–8859–4\"", 
        MAILOPTIONS, 
            "X–Priority: 3", 
            "X–MSMail–Priority: Normal", 
            "X–Mailer: Microsoft Outlook Express 10.31.112.206", 
            "X–MieOLE: Produced By Microsoft MimeOLE V5.00.2919.6700", 
        MAILDATA,
            "AttachFile={P_Attachment}",
        LAST ); 

0 Likes
4 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: "To" field is blank in the email sent from SMTP

Hi,

Is the sender a real accoun or a dummy one?

Regards,

Shlomi

 

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: "To" field is blank in the email sent from SMTP

Hi

Just to understand, where do you check that the "To" field is empty?

Is it in the mail program, then the mail must have correct to information, othewise it would not get there.

Is it on the mailserver, where there are some errors

Also want to point out that the screendump and the code-snippet don't match, from-addresses are different.

br /ola


Please mark post as solved if your problems or questions is/are resolved.
If this post was valuable to you, please consider kudo it.

 

.
0 Likes
Highlighted
Trusted Contributor.
Trusted Contributor.

Re: "To" field is blank in the email sent from SMTP

The sender is a real account, i have modified the actual mail-id in the example.

0 Likes
Highlighted
Trusted Contributor.
Trusted Contributor.

Re: "To" field is blank in the email sent from SMTP

The "To" field is empty in the mail program (Outlook).

It gets delivered correctly, but the To field is blank as shown on the attachment,

The mail-id in the code-snipped is just an example.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.