Highlighted
Regular Contributor.
Regular Contributor.
236 views

random SSL protocol error in web_concurrent

Hi

I've a web_concurrent with 18 web_url.

Some iterations pass, some fail : "SSL protocol error" occurs to one ore two web_url (always the same two web_rul).

The error is "ssl_handle_status encounter error : SSL_ERROR_SSL, error message : error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac   [MsgId: MMSG-26000]".

I fix the problem cutting the web_concurrent in 3 web_concurrent of 6 web_url (since LR uses 6 sockets). "SSL protocol error" never occurs again.

However I'd like to know how if there is an explanation or if it's just a bug.

 

Thanks for any (good 😉 idea

 

Tom

 

 

0 Likes
1 Reply
Highlighted
Respected Contributor.
Respected Contributor.

Re: random SSL protocol error in web_concurrent

Hello,

Greetings,

Could you attach the problematic script so I can debug it and then confirm if this is a bug or if there is a way to solve it different than the one you shared?

Awaiting on your response,

Warm regards,

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.