Highlighted
Contributor.
Contributor.
289 views

web tours start server is not opening

When i tried to open the server file it is opening and closing like a flash. If i restart the windows and try  to open the file it will open, if i close that file and when i tried to open it again it was not opening. Can anybody help me with this please

Labels (1)
Tags (1)
0 Likes
6 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: web tours start server is not opening

Hello,

Did you follow all the instructions in the guide exactly as described here?
https://admhelp.microfocus.com/lr/en/12.56-12.57/help/WebHelp/Content/Tutorial/WebTours.htm

If yes, please provide more details including logs and check if the listening port is occupied when started for the second time.

Make sure the PATH environment variable is configured correctly as well.

Regards,

Gil

0 Likes
Highlighted
Contributor.
Contributor.

Re: web tours start server is not opening

I followed the instructions shown in the link you given but there is no use i'm still facing the issues mentioned below. Help me out

0 Likes
Highlighted
Contributor.
Contributor.

Re: web tours start server is not opening

Yes, I have followed the steps as mentioned in link you given but still i'm facing the issue. So here i'm attaching the log files as asked.

(Make sure the PATH environment variable is configured correctly as well) I don't known how find this, can u please explain to get this to you

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: web tours start server is not opening

path is an environment variable in your Windows operating system.

Check this error message:
Can't locate systemPaths in @INC

It is there in your logs and might point on the issue.

Gil

Tags (1)
0 Likes
Highlighted
Contributor.
Contributor.

Re: web tours start server is not opening

[error] [client 127.0.0.1] CGI::param called in list context from C:/WebTours/cgi-bin/login.pl line 287, this can lead to vulnerabilities. See the warning in "Fetching the value or values of a single named parameter" at C:/Strawberry/perl/vendor/lib/CGI.pm line 412., referer: http://127.0.0.1:1080/cgi-bin/nav.pl?in=home

[error] [client 127.0.0.1] Premature end of script headers: reservations.pl, referer: http://127.0.0.1:1080/cgi-bin/welcome.pl?page=search

[error] [client 127.0.0.1] Can't locate ctime.pl in @INC (@INC contains: . C:/WebTours/cgi-bin C:/Strawberry/perl/site/lib C:/Strawberry/perl/vendor/lib C:/Strawberry/perl/lib) at C:/WebTours/cgi-bin/reservations.pl line 8., referer: http://127.0.0.1:1080/cgi-bin/welcome.pl?page=search

 

these were errors i'm facing now 

I'm attaching the images regarding first error and i don't ask me to check the paths or files about remaining errors because i didn't find or understand anything about them. So, please help me out from these 3 errors

0 Likes
Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: web tours start server is not opening

Hi @Aditya Ram K ,

The error.log indicates it cannot find systemPaths file which is supposed to be in the same folder of welcome.pl (C:/WebTours/cgi-bin/welcome.pl).

Can you please recheck your installation of WebTour?

Thanks,

Tedy

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.