Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Trusted Contributor.. Ivan Laszik Trusted Contributor..
Trusted Contributor..
985 views

Citrix Desktop in MultiProtocol script

Jump to solution

In my environment there is a citrix storefront website which hosts applications and desktops reachable via citrix. I have a vugen multiprotocol script which handles the connection to the storefront website and connects to the published citrix application using ctrx_nfuse_connect function. The web part is heavily parameterized so that it can be adapted easily to new storefront useraccounts and published applications. I use this one script template for several citrix applications by simply givving to a parameter the name of the application as it is visible on the storefront website. In short the web part code gets the URL of the .ica file and passes it to ctrx_nfuse_connect, from where the citrix part starts. I then record the citrix part in a new vugen project, then copy the code to the multiprotocol script after the ctrx_nfuse_connect function and all is well. We have several such vugen scripts working well.

Now comes my issue. I must loadtest an application on a remote machine to which the remote desktop connection is done via Citrix. On the citrix storefront website the connection is published as a Citrix Desktop, not an application. When launching it a Citrix window opens in which an actual desktop connection to the windows server is made, similar to Microsoft RDP, but inside a Citrix window. If I download the .ica file and start a new Vugen single protocol citrix project, and configure in the recording options the .ica file, all is well, it connects to the desktop and I can record and replay. However, if I use my multiprotocol web+citrix script, by givving the name of the published desktop to the specific parameter, it does find it, but the following thing happens: the ICA client window contains the text "Initializing..." and the citrix desktop window opens in a separate window and the script does not recognize this new window. The ctrx_nfuse_connect function now waits and does not recognize the connection as started, it just says "Connecting via NFUSE portal" and "Setting connection option "ICAFILE" to ..." and after a while it times out, and the script stops with error, ofcourse. I also changed the script to download the ica file and use ctrx_set_connect_opt to connect, but the same happens. I cannot understand why this is happening. 

Any help is appreciated.

Ivan.

0 Likes
1 Solution

Accepted Solutions
Trusted Contributor.. Ivan Laszik Trusted Contributor..
Trusted Contributor..

Re: Citrix Desktop in MultiProtocol script

Jump to solution

Issue has been solved by loadrunner support. Our citrix desktops have the desktop toolbar enabled, and because of this loadrunner cannot handle it in a ica+web script. If the toolbar is diabled via the ica file, parameter "connectionbar=0", then the desktop opens in loadrunners ica window even in a ica+web script and can handle it. the connectionbar parameter can be controlled from the citrix storefront or after ica file download writing code to change it.

View solution in original post

6 Replies
Micro Focus Expert
Micro Focus Expert

Re: Citrix Desktop in MultiProtocol script

Jump to solution

Hi,

What version of Citrix Receiver do you use on VuGen machine ? What version of Citrix Storefront and XenApp/XenDesktop do you use ?

Can you share the output log with extended log enabled ? Did you checked what is different in ICA file when you download from browser and VuGen ?

Can you check if the new window parent really belongs to runCitrixClient.exe with Process Explorer ?

Best regards,

Marcel

0 Likes
Trusted Contributor.. Ivan Laszik Trusted Contributor..
Trusted Contributor..

Re: Citrix Desktop in MultiProtocol script

Jump to solution

Citrix Receiver version is 4.9.3000.11. I am not admin of the citrix infrastructure and do not know the admins. How can I find out what version of Citrix Storefront and XenApp/XenDesktop is used? I ran the script with extended logging, however it contains company info, I can not share it all. For what should I look for, or what part to share? Maybe I can exclude sensitive data.

There is no runCitrixClient.exe process when the script is running. The Citrix Desktop is child of process CDViewer which is from the citrix installation folder. After the script times out and VuGens ICA Client window closes, the citrix desktop window stays open, and I can click in it.

The ica file seems identical (except for session specific information) regardless of how or from which application I download it: vugen script or browser. I used the ica file downloaded from the vugen script to test it in a standalone citrix script, and the desktop opened in vugens ica window, as it should. Only in the mixed protocol it opens in a separate window.

VuGen version is 12.55.

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Citrix Desktop in MultiProtocol script

Jump to solution

Hi,

You can send me in PM the the replay log output.txt and the main file that you use, it is Action.c if you did not change it. You can remove any sensitive data.

Best regards,

Marcel

 

0 Likes
Highlighted
ctneen Contributor.
Contributor.

Re: Citrix Desktop in MultiProtocol script

Jump to solution

HI Ivan ,

 

Does your issue got resolved ? - I am also facing same issue. 

 

Thanks

0 Likes
Trusted Contributor.. Ivan Laszik Trusted Contributor..
Trusted Contributor..

Re: Citrix Desktop in MultiProtocol script

Jump to solution

Hello,

Issue is not solved, I opened a case with MF. I have a feeling this is a bug.

BR,

Ivan.

0 Likes
Trusted Contributor.. Ivan Laszik Trusted Contributor..
Trusted Contributor..

Re: Citrix Desktop in MultiProtocol script

Jump to solution

Issue has been solved by loadrunner support. Our citrix desktops have the desktop toolbar enabled, and because of this loadrunner cannot handle it in a ica+web script. If the toolbar is diabled via the ica file, parameter "connectionbar=0", then the desktop opens in loadrunners ica window even in a ica+web script and can handle it. the connectionbar parameter can be controlled from the citrix storefront or after ica file download writing code to change it.

View solution in original post

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.