Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Highlighted
Yallani Frequent Contributor.
Frequent Contributor.
93 views

Controller showing "0.000" min,max,avg response time for transactions, in Truclient Mobile Protocol.

Hello,

In LR 12.60, I have recorded a script with Truclient Native Mobile Protocol  (Using Mobile Emulator), Enhanced it and when I replay the script in VuGen it is giving me measurement like Duration  as shown in picture

        Screenshot (17)_LI.jpg 

But In Controller, during execution of same script with 2 users (2 iterations each) - Min, Max, Average response time for same transactions was shown as "0.000"  and even Analysis reports,for the same, showed below results:

           Screenshot (19).png

Average transaction response time graph:

        Screenshot (20).png

Because of this, analysis report not creating graphs for Running Vusers, Hits per Second and Throughput.

Can someone help explaining what could be the reason for the controller showing "0.000" for response time?

Thanks 

 

 

0 Likes
2 Replies
Nakkeeran Valued Contributor.
Valued Contributor.

Re: Controller showing "0.000" min,max,avg response time for transactions, in Truclient Mo

Hi @Yallani ,

It looks like the response times, when run from controller are close to 0. I assume, protocol is Truclient-Mobileweb and the transactions have proper start and end points defined.

Can you please share your Run-time settings of the script.

Edit: I see that you are testing advantage shopping application and the sign-out time seems higher to me. If possible please share the script.

0 Likes
Yallani Frequent Contributor.
Frequent Contributor.

Re: Controller showing "0.000" min,max,avg response time for transactions, in Truclient Mo

Hi Nakkeeran,

The script is recorded using Truclient-NativeMobile protocol (Not Truclient-MobileWeb) and yes transactions have properly defined start and end points.

I have recorded the same application using Truclient- MobileWeb protocol and there controller is giving proper response time (0.xx sec).

Attaching the Runtime Settings (JSON file) which I used in test and Script SS as below:

Screenshot (35)_LI.jpg

Screenshot (45)_LI.jpg

 

Thank You!

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.