Absent Member.. Indy_Jason Absent Member..
Absent Member..
830 views

Launching IE as a different user in a HTTP/HTML protocol record?

With IE, you can Shift/Right click to launch it as a different user.

 

Is it possible to do record a script using Vugen 12 HTTP/HTML where IE can be launched and recorded as a different user? I'm not seeing anything in the Recording settings.

 

I thought maybe this might be possible by creating a .bat file and recording it as an application but not sure if this is the desirable approach or feasible.

 

Win 7 64x

IE 11

Vugen 12.02

0 Likes
4 Replies
Absent Member.. Indy_Jason Absent Member..
Absent Member..

Re: Launching IE as a different user in a HTTP/HTML protocol record?

A bit more information on this...

 

I see in the code generation logs that I am getting a 401 auth error in the record process.

 

I tried launching Vugen using a "run as" using valid credentials but this did not work.

 

Something about IE being launch by Vugen is causing there to be the 401 auth error.

 

Note this is on RECORD not Replay.

0 Likes
Respected Contributor.. KajFeis Respected Contributor..
Respected Contributor..

Re: Launching IE as a different user in a HTTP/HTML protocol record?

When  you record, do you see how the credentials are send? 

Have you tried experimenting with the web_set_user function?

0 Likes
Absent Member.. Indy_Jason Absent Member..
Absent Member..

Re: Launching IE as a different user in a HTTP/HTML protocol record?

Thanks for the reply.

 

I'm not seeing anything specific in the script generation. I know it uses an active directory authentication to allow access to the initial web page. My current user ID and pass that I'm logged in with has this access.

 

A symptom is when I try to navigate to to the test URL using IE11 manually, it works fine. When I try in the recording process it says 'Page Cannot Be displayed".

 

I don't know if there is a cert issue or somehow the record process is losing my authentication credentials?

 

As far as web_set_user...isn't that more for replay? I can't even get anything recorded.

0 Likes
Highlighted
MCusanelli Respected Contributor.
Respected Contributor.

Re: Launching IE as a different user in a HTTP/HTML protocol record?

Did you happen to find a resolution to this? I'm trying to do the same thing because of SSO. I need to be able to run IE as a different user than the recording user so we can authenticate.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.