Having problems with your account or logging in?
A lot of changes are happening in the community right now. Some may affect you. READ MORE HERE
Super Contributor.. PKaye Super Contributor..
Super Contributor..
1093 views

ALM Integration with Mobile Center - Incorrect Login - Solution

Hi,

I thought it worth posting this as it wasn't that intuitive imo.  To use the ALM Integration with Mobile Center, which allows the selection of the device from the test set, it is necessary to have the right version of ALM and perform the configuration from the help.  The COMMUNITY_SECURITY_PASSPHRASE for Mobile Center must be set to the same as in ALM.  There is one of those notes there.... but the section begins with an If, and talks about Single Sign-On tokens.  I ignored because of not using SSO...... this was wrong.  Set the value in Mobile Center to the same value as in ALM.

Paul

0 Likes
4 Replies
Micro Focus Expert
Micro Focus Expert

Re: ALM Integration with Mobile Center - Incorrect Login - Solution

Hi Paul,

This is correct: all HPE products use SSO to communicate with each other, Mobile Center is not an exception there.

As you can see in ALM configuraiton, you don't provide user/pass for Mobile Center. This is because SSO string is used instead.

Hence, those strings must match in both tools.

0 Likes
Sripriya1 Absent Member.
Absent Member.

Re: ALM Integration with Mobile Center - Incorrect Login - Solution

Thank you so much for this information. I am 100% sure that the communication_security_passphrase in the SSO settings in MC matches the one configured in ALM Site Configuration tab in ALM Site Admin.

Still, I am getting the error. I have restarting the MC server, runinng the Modify Configuration wizard but no luck.

Any thoughts?

Thanks,

Sripriya

0 Likes
Highlighted
Trusted Contributor.. veeru24 Trusted Contributor..
Trusted Contributor..

Re: ALM Integration with Mobile Center - Incorrect Login - Solution

Hi SriPriya,

We are getting the same error whiel testing the connection from ALM to MC,

we see same passphrase in both the server, still noluck, can you please let us know what you did to mitigate this?

0 Likes
Utpal Contributor.
Contributor.

Re: ALM Integration with Mobile Center - Incorrect Login - Solution

Hi,

I am getting a similar error, but after using a different passphrase, I able establish the connection again with ALM and MC.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.